Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Failed to renew token: Kind: kms-dt during running Pig job

avatar
Rising Star

Dear all!

 

I have kerberized cluster on Cloudera Express 5.9.3, Java Version: 1.7.0_67.

Since I turned on HDFS Data At Rest Encryption using Java Keystore KMS I recieve an error in Pig job

 

 Failed to renew token: Kind: kms-dt, Service: 10.6.1.44:16000, Ident: (kms-dt owner=hdfs, renewer=yarn, realUser=, issueDate=1547451323413, maxDate=1548056123413, sequenceNumber=2, masterKeyId=2)

 

Yarn log:

 

Caused by: java.io.IOException: Keystore was tampered with, or password was incorrect

Caused by: java.security.UnrecoverableKeyException: Password verification failed

 

I have checked the pessword by doing keytool -list, the password is correct.

 

Please, help me to resolve this problem.

 

1 ACCEPTED SOLUTION

avatar
Rising Star

Passwords for trust store and keystore must be the same. After changing the password for trust store everything went good.

View solution in original post

1 REPLY 1

avatar
Rising Star

Passwords for trust store and keystore must be the same. After changing the password for trust store everything went good.