Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Failed to start role of YARN Queue Manager

avatar
Explorer

I encountered an error with the following description after installing YARN Queue Manager:

 

Caused by: org.h2.jdbc.JdbcSQLNonTransientException: Log file error: "/var/lib/hadoop-yarn/config-service.trace.db", cause: "java.io.FileNotFoundException: /var/lib/hadoop-yarn/config-service.trace.db (Permission denied)" [90034-198] at org.h2.message.DbException.getJdbcSQLException(DbException.java:502) at org.h2.message.DbException.getJdbcSQLException(DbException.java:427) ... 38 more Caused by: java.io.FileNotFoundException: /var/lib/hadoop-yarn/config-service.trace.db (Permission denied)

 

DanhH_0-1689065561434.png

I have searched, but I couldn't find anyone experiencing the same error as me. Could you please assist me?😥

2 REPLIES 2

avatar
Super Collaborator

Do this to fix your issue:

change the config something like this ...

add yaml env variable "${dir_for_config}" note that '~/' is bash expansion [0] eg: ... conf.yml

dbConfig: dbType: H2 driver: org.h2.Driver url: jdbc:h2:~/${dir_for_config}/config-service;DB_CLOSE_DELAY=-1;AUTO_RECONNECT=TRUE;DB_CLOSE_ON_EXIT=FALSE

 In CM WebUI CM> Yarn Queue...>Conf>

find "YARN Queue Manager Service Environment Advanced Configuration Snippet (Safety Valve)"add: key: dir_for_config value: x

avatar
Super Collaborator

Hi @DanhH ,

Please accept this as a solution if it helped.