Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Failure during ansible-playbook run using vagrant up single node Metron

Solved Go to solution

Failure during ansible-playbook run using vagrant up single node Metron

Explorer

I am seeing the following error message when performing the single node Metron setup using Vagrant. I've repeated the process and can confirm the issue happens each time.

TASK: [ambari_common | Add key pairs to existing authorized_keys] *************
fatal: [node1] => could not locate file in lookup: /tmp/keys/{{ item }}.pub


FATAL: all hosts have already failed -- aborting


PLAY RECAP ********************************************************************
           to retry, use: --limit @/Users/tbenton/metron_full_install.retry


node1                      : ok=9    changed=8    unreachable=1    failed=0


Ansible failed to complete successfully. Any error output should be
visible above. Please fix these errors and try again.
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Failure during ansible-playbook run using vagrant up single node Metron

Explorer

Upgrading to Ansible 2.0+ fixed the issue here. I am able to continue the build now after upgrading. It was likely due to an older version of Ansible that I had installed.

View solution in original post

6 REPLIES 6
Highlighted

Re: Failure during ansible-playbook run using vagrant up single node Metron

Explorer

Hey Tom,

Thanks for trying out metron, first off :) Anything going on before that log? Also, what's your platform and version of vagrant installed?

Highlighted

Re: Failure during ansible-playbook run using vagrant up single node Metron

Explorer

Everything else is showing success through the mvn apache-rat and integration-test. I only get an error at this point.

Mac OS X 10.11.4

Vagrant 1.8.1

VirtualBox 5.0.16

Highlighted

Re: Failure during ansible-playbook run using vagrant up single node Metron

Explorer
@cstella

Log output from ansible-playbook run

==> node1: Running provisioner: ansible...
    node1: Running ansible-playbook...


PLAY [ec2] ********************************************************************
skipping: no hosts matched


PLAY [ambari_*] ***************************************************************


GATHERING FACTS ***************************************************************
ok: [node1]


TASK: [libselinux-python | Install libselinux-python] *************************
changed: [node1]


TASK: [yum-update | Yum Update Packages] **************************************
changed: [node1]


TASK: [epel | Get epel-repo rpm] **********************************************
changed: [node1]


TASK: [epel | Install epel-repo rpm] ******************************************
changed: [node1]


TASK: [ntp | Install ntp] *****************************************************
changed: [node1]


TASK: [ntp | Ensure ntp is running and enabled] *******************************
changed: [node1]


TASK: [ambari_common | Check OS Version] **************************************
skipping: [node1]


TASK: [ambari_common | Generate ssh key pair for "root"] **********************
changed: [node1]


TASK: [ambari_common | Fetch the generated public key] ************************
changed: [node1]


TASK: [ambari_common | Add key pairs to existing authorized_keys] *************
fatal: [node1] => could not locate file in lookup: /tmp/keys/{{ item }}.pub


FATAL: all hosts have already failed -- aborting


PLAY RECAP ********************************************************************
           to retry, use: --limit @/Users/tbenton/metron_full_install.retry


node1                      : ok=9    changed=8    unreachable=1    failed=0


Ansible failed to complete successfully. Any error output should be
visible above. Please fix these errors and try again.

Highlighted

Re: Failure during ansible-playbook run using vagrant up single node Metron

Rising Star

HI Tom,

I have a couple of questions- can you give me your ansible --version from your Mac and the top hash from the git log?

Also - after it gives the error, was anything left in /tmp/keys?

Thanks!

-David...

Highlighted

Re: Failure during ansible-playbook run using vagrant up single node Metron

Explorer

tbenton$ ansible --version

ansible 1.9.0.1

configured module search path = None

[vagrant@node1 ~]$ ls /tmp

epel-release.rpm hosts ks-script-u_G5MN ks-script-u_G5MN.log vboxguest-Module.symvers yum.log

which git log did you want the hash from?

Highlighted

Re: Failure during ansible-playbook run using vagrant up single node Metron

Explorer

Upgrading to Ansible 2.0+ fixed the issue here. I am able to continue the build now after upgrading. It was likely due to an older version of Ansible that I had installed.

View solution in original post

Don't have an account?
Coming from Hortonworks? Activate your account here