Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Falcon UI not working

Expert Contributor

I restarted Falcon Server and getting this error:

HTTP ERROR: 503 Problem accessing /index.html. Reason: SERVICE_UNAVAILABLE


Expert Contributor

The issue has been resolved. The entity was corrupt and we restored the falcon Store and WebApp.

View solution in original post


New Contributor

Cut'n'pasteable / idempotent:

su - falcon
l_hdp_ver=$(ls -d /usr/hdp/[0-9]* | head -n 1 | sed -e 's#^.*/\([0-9].*\)#\1#')
yes | cp je-5.0.73.jar /usr/hdp/$l_hdp_ver/falcon/webapp/falcon/WEB-INF/lib
chmod 644 /usr/hdp/$l_hdp_ver/falcon/webapp/falcon/WEB-INF/lib/je-5.0.73.jar


I also just hit this issue after upgrading to

Expert Contributor

You need to register download and register the bdb jar with ambari server before starting Falcon server. This is required from HDP 2.5 or later now The following steps would help

  1. wget -O je-5.0.73.jar
  2. cp je-5.0.73.jar /usr/share/
  3. chmod 644 /usr/share/je-5.0.73.jar
  4. ambari-server setup --jdbc-db=bdb --jdbc-driver=/usr/share/je-5.0.73.jar
  5. ambari-server restart
  6. Restart Falcon service


It worked Perfectly Venkat R...


Hi Venkat, I did the above, but the issue still persists on my cluster. Do you have any idea what else might be wrong or what's worth checking? Basically I get the same error whether I try to run a service check or see the falcon version

ERROR: Unable to initialize Falcon Client object. Cause : Could not authenticate, Authentication failed, URL: <a href="http://<host>:15000/api/options?,">http://:15000/api/options?,>:15000/api/options?,</a>><host>:15000/api/options?, status: 503, message: Service Unavailable

In the falcon.application.log there are the following errors. From what I understood, adding the je-5.0.73.jar file should've solved this problem, but it persists and I run out of ideas.

2017-07-12 09:07:42,568 ERROR - [main:] ~ Failed to initialize service org.apache.falcon.metadata.MetadataMappingService (ServiceInitializer:49)
java.lang.RuntimeException: GraphFactory could not instantiate this Graph implementation [com.thinkaurelius.titan.core.TitanFactory].
        at org.apache.falcon.metadata.MetadataMappingService.initializeGraphDB(
        at org.apache.falcon.metadata.MetadataMappingService.init(
        at org.apache.falcon.service.ServiceInitializer.initialize(
        at org.apache.falcon.listener.ContextStartupListener.contextInitialized(
        at org.mortbay.jetty.handler.ContextHandler.startContext(
        at org.mortbay.jetty.servlet.Context.startContext(
        at org.mortbay.jetty.webapp.WebAppContext.startContext(
        at org.mortbay.jetty.handler.ContextHandler.doStart(
        at org.mortbay.jetty.webapp.WebAppContext.doStart(
        at org.mortbay.component.AbstractLifeCycle.start(
        at org.mortbay.jetty.handler.HandlerWrapper.doStart(
        at org.mortbay.jetty.Server.doStart(
        at org.mortbay.component.AbstractLifeCycle.start(
        at org.apache.falcon.util.EmbeddedServer.start(
        at org.apache.falcon.FalconServer.main(
Caused by: java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(
        at java.lang.reflect.Method.invoke(
        ... 15 more
Caused by: java.lang.NoClassDefFoundError: com/sleepycat/je/LockMode
        at com.thinkaurelius.titan.diskstorage.berkeleyje.BerkeleyJEStoreManager.<clinit>(
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(
        at com.thinkaurelius.titan.util.system.ConfigurationUtil.instantiate(
        at com.thinkaurelius.titan.diskstorage.Backend.getImplementationClass(
        at com.thinkaurelius.titan.diskstorage.Backend.getStorageManager(
        at com.thinkaurelius.titan.graphdb.configuration.GraphDatabaseConfiguration.<init>(
        ... 20 more
Caused by: java.lang.ClassNotFoundException:
        at java.lang.ClassLoader.loadClass(
        at sun.misc.Launcher$AppClassLoader.loadClass(
        at java.lang.ClassLoader.loadClass(
        ... 29 more
2017-07-12 09:07:42,569 ERROR - [main:] ~ Failed startup of context org.mortbay.jetty.webapp.WebAppContext@351f2244{/,/usr/hdp/current/falcon-server/server/webapp/falcon} (log:87)
java.lang.RuntimeException: org.apache.falcon.FalconException: java.lang.RuntimeException: GraphFactory could not instantiate this Graph implementation [com.thinkaurelius.titan.core.TitanFactory].
        at org.apache.falcon.listener.ContextStartupListener.contextInitialized(


Great answer @Venkat Ranganathan your answer fixed our problem


Currently my ambari server is setup using mysql DB and corresponding jdbc driver. If I do the setup again to specify a different DB for Falcon will that cause inconsistency? Or I can just setup mysql for ambari and bdb for falcon?

Master Mentor

@Swaapnika Guntaka

As of HDP 2.5.3, you need to install the Berkeley DB prior to upgrading or installing Falcon. That might be the problem you are encountering. You might try the following: [Updated content below]

1.Download the required Berkeley DB implementation file.

wget –O je-5.0.73.jar

2.Log in to the Ambari server with administrator privileges.

su – root

3.Copy the file to the Ambari server share folder.

cp je-5.0.73.jar /usr/share/

4.Set permissions on the file to owner=read/write, group=read, other=read.

chmod 644 /usr/share/je-5.0.73.jar

5.Configure the Ambari server to use the Berkeley DB driver.

ambari-server setup --jdbc-db=bdb --jdbc-driver=/usr/share/je-5.0.73.jar

6.Restart the Ambari server.

ambari-server restart

7.Restart the Falcon service from the Ambari UI.

You need to have administrator privileges in Ambari to restart a service.

1.In the Ambari web UI, click the Services tab and select the Falcon service in the left Services pane.

2.From the Falcon Summary page, click Service Actions > Restart All.

3.Click Confirm Restart All.

When the service is available, the Falcon status displays as Started on the Summary page.

Further information and manual install instructions are available in an article at


@Geoffrey Shelton Okot

I have downloaded the jar already. The question I have is since I’ve already setup the ambari server using mysql DB and mysql jdbc driver, would doing a setup again with bdb and it’s jar cause a conflict? Or can I set up ambari using any number of databases like for eg mysql for ambari, derby for oozie, bdb for falcon etc

Master Mentor

@Swaapnika Guntaka

That will run independently it won't interfere with the Mysql or any other database.Falcon doesn't use the classic db's like run. Before you proceed make sure Falcon is not running ,kill any rogue falcon process