Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

File conflict error during upgrade sandbox to HDP 2.4.2

Solved Go to solution

File conflict error during upgrade sandbox to HDP 2.4.2

New Contributor

Hello,

I tried to upgrade a freshly deployed 2.4.0 sandbox to 2.4.2 HDP based on these instructions:

http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.2.0/bk_upgrading_Ambari/content/_preparing_to_up...

I have used RedHat6 HDP 2.4.2 related repo URLs what listed here:

http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.2.0/bk_Installing_HDP_AMB/content/_hdp_24_reposi...

but I faced with the following error:

2016-05-11 12:41:29,105 - Package Manager failed to install packages. Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install '--disablerepo=HDP-*' --enablerepo=HDP-2.4.2.0,HDP-UTILS-2.4.2.0 zeppelin' returned 1. Transaction Check Error:
  file /etc/zeppelin/conf.dist/shiro.ini from install of zeppelin_2_4_2_0_258-0.6.0.2.4.2.0-258.el6.noarch conflicts with file from package zeppelin_2_4_0_0_169-0.6.0.2.4.0.0-169.el6.noarch
  file /etc/zeppelin/conf.dist/zeppelin-env.sh.template from install of zeppelin_2_4_2_0_258-0.6.0.2.4.2.0-258.el6.noarch conflicts with file from package zeppelin_2_4_0_0_169-0.6.0.2.4.0.0-169.el6.noarch
  file /etc/zeppelin/conf.dist/zeppelin-site.xml.template from install of zeppelin_2_4_2_0_258-0.6.0.2.4.2.0-258.el6.noarch conflicts with file from package zeppelin_2_4_0_0_169-0.6.0.2.4.0.0-169.el6.noarch
  file /var/lib/zeppelin/notebook/2A94M5J1Z/note.json from install of zeppelin_2_4_2_0_258-0.6.0.2.4.2.0-258.el6.noarch conflicts with file from package zeppelin_2_4_0_0_169-0.6.0.2.4.0.0-169.el6.noarch

There was no error regarding ambari-server upgrade. I have attached the detailed logs.

Could you please help me how to fix this issue?

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: File conflict error during upgrade sandbox to HDP 2.4.2

New Contributor

@Kalman Jantner

The work around for this issue is to try to manually delete zeppelin packages of the current version from the terminal using

yum remove zeppelin_2_4_0*

Then click on to the down arrow of Perform Upgrade button and select Reinstall Packages.

Check if this works. If you want to downgrade your cluster later, delete the zeppelin package of 2.4.2 version and downgrade it to 2.4.0.

5 REPLIES 5

Re: File conflict error during upgrade sandbox to HDP 2.4.2

@Kalman Jantner

Can you try $yum clean all and retry. Check if helps.

Re: File conflict error during upgrade sandbox to HDP 2.4.2

New Contributor

I just have retried it after "$yum clean all" and a reboot but I got the same error.

Re: File conflict error during upgrade sandbox to HDP 2.4.2

New Contributor

@Kalman Jantner

The work around for this issue is to try to manually delete zeppelin packages of the current version from the terminal using

yum remove zeppelin_2_4_0*

Then click on to the down arrow of Perform Upgrade button and select Reinstall Packages.

Check if this works. If you want to downgrade your cluster later, delete the zeppelin package of 2.4.2 version and downgrade it to 2.4.0.

Re: File conflict error during upgrade sandbox to HDP 2.4.2

New Contributor

Thank you @Mushtaq Rizvi! That remove solved my problem.

Re: File conflict error during upgrade sandbox to HDP 2.4.2

New Contributor

Thank you @Mushtaq Rizvi, My problem was solved with this command.