Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
INSERT OVERWRITE DIRECTORY '/tmp' ROW FORMAT DELIMITED FIELDS TERMINATED BY '\t' STORED AS TEXTFILE SELECT visit_id, ivm from abcd.xyz WHERE feed_date BETWEEN '2006-04-01' and '2006-05-01' AND ivm IS NOT NULL limit 10;
Error: Error while compiling statement: FAILED: HiveAccessControlException Permission denied: user [rvchinta] does not have [WRITE] privilege on [/tmp] (state=42000,code=40000) 0: jdbc:hive2://hostname.abc.com:8443>
ranger policy /tmp has 777 to public
HDP version 2.6.1
Created 01-26-2018 07:47 PM
I can confirm that I had the same problem on HDP 2.6.3. Like suggested, using the fully qualified path (hdfs://<cluster>/path) makes it work.
Created 07-10-2017 09:29 PM
I do not see this permission denied in ranger audit as well.
Created 02-09-2018 06:20 PM
INSERT OVERWRITE DIRECTORY "hdfs://sandbox-hdp.hortonworks.com/tmp/hey2" SELECT * FROM mytable;
Created 05-15-2018 08:21 AM
Hi,
Is there a workaround solution for the above or is it a behaviour of 2.6.3 and above?
Created 07-10-2017 09:38 PM
i updated directory path to hdfs:CLUSTERNAMEHA/tmp and it worked.
Created 01-26-2018 07:47 PM
I can confirm that I had the same problem on HDP 2.6.3. Like suggested, using the fully qualified path (hdfs://<cluster>/path) makes it work.