Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

GetSFTP error




Can anyone pls help to solve the below error.

File has complete permission

-rwxrwxrwx. 1 root root 120801311 Mar 15 06:32 kafka_experiment.csv

still im getting filenot found error while i try to get the data from remote machine.

and i tried all the ways to give remote path different way.


@hema moger Any reason why you are using a back slash in the path?


there s no specific reason for that, i am just trying all possible ways wheather it will work or not @Sandeep Nemuri

New Contributor


Can you correct remote path...

It should /root/template_writing/kafka_experiment.csv


It's giving the same error.

@hema moger can you please do a pwd and see the actual path where the file is present?

@hema moger

It appears your GetSFTP processor configuration is wrong. You entered the filename in the "Remote Path" field, so the processor is treating that filename as part of the directory path and then trying to look for all files within that complete target directory path.

If you only want the processor to consume that 1 file, try setting that file name in the "File Filter Regex" instead:


Thank you,



@Matt Clarke

I tried the above setting file filter regex,but still its giving could not find the file on remote path.i am not understanding this how to solve.

but manually if i do sftp on nifi running machine its connecting to remote machine.

kindly help.


@hema moger

Make sure you do not have any leading or trailing whitespaces in either the "Remote Path" or "File Filter Regex" property values.

Can you share some screenshots of you connecting manually from command line on the nifi server to this SFTP server?

Once connected execute following:


cd \root\template_writing

ls -latrh

Thank you,


New Contributor

@hema moger please could you supply the answer i.e. what worked for you to be able to resolve this error.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.