Support Questions
Find answers, ask questions, and share your expertise

Getting error "User session not found 403" when using zeppelin with livy


So we have a kerberized cluster and have integrated ldaps with zeppelin. But when i try to use livy i get the following error

ERROR [2016-12-01 10:00:02,442] ({pool-2-thread-4}[createSession]:128) - Error getting session for user java.lang.Exception: Cannot start spark. at org.apache.zeppelin.livy.LivyHelper.createSession( at org.apache.zeppelin.livy.LivySparkSQLInterpreter.interpret( at org.apache.zeppelin.interpreter.LazyOpenInterpreter.interpret( at org.apache.zeppelin.interpreter.remote.RemoteInterpreterServer$InterpretJob.jobRun( at at org.apache.zeppelin.scheduler.FIFOScheduler$ at java.util.concurrent.Executors$ at at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201( at java.util.concurrent.ScheduledThreadPoolExecutor$ at java.util.concurrent.ThreadPoolExecutor.runWorker( at java.util.concurrent.ThreadPoolExecutor$ at ERROR [2016-12-01 10:00:02,442] ({pool-2-thread-4}[interpret]:70) - Exception in LivySparkSQLInterpreter while interpret java.lang.Exception: Cannot start spark.

in zeppelin interpreter logs.

Also when i dont enable ldap for zeppelin (that is i log in as anonymous), I can see that job is been submitted to yarn but it fails as user is `zeppelin-clusterName`. But when i use ldap with zeppelin it is not even getting submit to yarn.



Hey @kbadani, thanks for getting back. I did this but no luck, I also checked after restarting the services but the 403 error persists.

@Bhavin Tandel Can you please post what error you are getting in livy server logs ?


@kbadani Sorry for the delay, I have attached the live.out log


Expert Contributor

yarn app is started, could you check the yarn app log ? appid : application_1481021618182_0004


So guys @kbadani and @jzhang the issue finally got solved and thank you for your support. It was very trivial but very important property, livy.superuser was set to `zeppelin-<cluster name in uppercase>` but the principal was in lower case 😛 . And changing that solved the issue, @kbadani You pointed out that property but I didnt know that it is case sensitive.

View solution in original post

@Bhavin Tandel good to know 🙂 Thanks