Support Questions
Find answers, ask questions, and share your expertise

HBase Region Server keeps stopping after I restart with Ambari

When I restart HBase Region server from Ambari, it starts without any error but quickly stops.

When I checked in /var/log/hbase, I found this error.

Exception in thread "main" java.lang.RuntimeException: Failed construction of Regionserver: class org.apache.hadoop.hbase.regionserver.HRegionServer at org.apache.hadoop.hbase.regionserver.HRegionServer.constructRegionServer(HRegionServer.java:3667) at org.apache.hadoop.hbase.regionserver.HRegionServerCommandLine.start(HRegionServerCommandLine.java:60) at org.apache.hadoop.hbase.regionserver.HRegionServerCommandLine.run(HRegionServerCommandLine.java:75) at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:76) at org.apache.hadoop.hbase.util.ServerCommandLine.doMain(ServerCommandLine.java:76) at org.apache.hadoop.hbase.regionserver.HRegionServer.main(HRegionServer.java:3691)

Any help would be appreciated.

Thanks.

1 REPLY 1

Cloudera Employee

@Sai Dileep

Did the issue start after an Ambari upgrade? In that case you might need to check the value for "hbase.bucketcache.size". Please check the below HCC thread for more details.

https://community.hortonworks.com/questions/10111/hbase-region-servers-not-starting-after-ambari-upg...

Also if you could paste the entire error stack, that would be more helpful.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.