Support Questions
Find answers, ask questions, and share your expertise

HDF 3.0 Shell in a box

Solved Go to solution

HDF 3.0 Shell in a box

Expert Contributor

Hi

I have installed HDF 3.0 on windows 7. I want to connect to the Vm via the browser (WEB SHELL CLIENT). But when i try to login to the sandbox i get the following error:

ssh: Could not resolve hostname sandbox.hortonworks.com: Name or service not known  

I see it tries to look for the hostname: sandbox.hortonwoks.com, however the sandbox name in case of HDF is : sandbox-hdf.hortonworks.com.

I have added this host name in windows/sys32/hosts file. Is there a setting where I need to make this change to make shell in a box work? How can I configure "shell in a box" to look for the correct hostname.

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Re: HDF 3.0 Shell in a box

Super Mentor

@Arsalan Siddiqi

You should be able to access the sandbox using "localhost" as well. Did you try that ? If it's not working then please refer to the following section:

.

Please take a look at the following file:

# cat  /etc/sysconfig/shellinaboxd

.

And in the output of the above file check if the hostname is correct? It should be somewhere in the following line:

# Simple configuration for running it as an SSH console with SSL disabled:
OPTS="-t -s /:SSH:sandbox.hortonworks.com --css white-on-black.css"

.

Correct the host name if it is wrong. (or unexpected)

The restart the service.

# service shellinaboxd start
# systemctl enable shellinaboxd.service
# netstat -nap | grep shellinabox

.

View solution in original post

2 REPLIES 2

Re: HDF 3.0 Shell in a box

Super Mentor

@Arsalan Siddiqi

You should be able to access the sandbox using "localhost" as well. Did you try that ? If it's not working then please refer to the following section:

.

Please take a look at the following file:

# cat  /etc/sysconfig/shellinaboxd

.

And in the output of the above file check if the hostname is correct? It should be somewhere in the following line:

# Simple configuration for running it as an SSH console with SSL disabled:
OPTS="-t -s /:SSH:sandbox.hortonworks.com --css white-on-black.css"

.

Correct the host name if it is wrong. (or unexpected)

The restart the service.

# service shellinaboxd start
# systemctl enable shellinaboxd.service
# netstat -nap | grep shellinabox

.

View solution in original post

Re: HDF 3.0 Shell in a box

Expert Contributor

Thanks! that fixed it. i had to change the hostname in the file. now it works!