Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HDF MPack not appearing when installed on HDP 3.0 cluster

Highlighted

HDF MPack not appearing when installed on HDP 3.0 cluster

Explorer

Hi,

I am trying to add the HDF 3.1.2 MPack to my HDP 3.0.0 cluster so that I can use NiFi (along with some HDP service). No matter which way I try and add it I cannot get it to appear in the stack and versions or Services sections of Ambari. I have tried adding the MPack via SSH to the on the master node (installed successfully), also on a fresh cluster I have tried registering the MPack in Cloudbreak and specifying that it be installed during the cluster deployment. Each time it states the MPack has been installed successfully but it is nowhere to be found in Ambari. I cannot find any section to add the base HDF URL as one document says to do nor can I find it to try and register a new version. Only the HDP 3.0 version is shown.

Does anyone have a suggestion as to where I'm going wrong?

Thanks,

Paul

2 REPLIES 2

Re: HDF MPack not appearing when installed on HDP 3.0 cluster

Super Mentor

@Paul Norris

As per website : https://supportmatrix.hortonworks.com/ (accessible with hortonworks support subscription) and this link : https://docs.hortonworks.com/HDPDocuments/HDF3/HDF-3.1.2/support-matrix.html

Ambari-2.7.0 is not compatable with HDF 3.1.2.0 .

You might need to install Ambari-2.6.2.2 inorder to support HDF-3.1.2.0 or lesser Ambari-2.6.x.x versions.

HDF-3.2 is releasing in some more days which will be compatible with Ambari-2.7. as of now Ambari-2.7 supports only HDP-3.0 installation .

Reference HCC Thread: https://community.hortonworks.com/questions/202708/installing-hdf-on-ambari-with-hdp-3000-fails.html...

Re: HDF MPack not appearing when installed on HDP 3.0 cluster

Explorer

@Jay Kumar SenSharma thanks for that information, that is disappointing. So from the looks of this if I am running HDP 3.0 which I think requires Ambari 2.7 (correct me if that is wrong) then there is currently no way for me to add an HDF MPack to HDP 3.0 until HDF 3.2 is released? Do you think this is correct?

When they say "in some more days" do you know is that this week, next week, next month, how many days is "some more"?

Thanks,

Paul

Don't have an account?
Coming from Hortonworks? Activate your account here