Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
01-15-2014
09:58 PM
- last edited on
05-13-2026
09:52 AM
by
cjervis
when i use hdfs comands it display errors:
hadoop fs -mkdir /user/,,myfile,, or "hadoop fs -put myfile.txt /user/,,/,,"
hadoop will display"Permission denied: user=root, access=WRITE, inode="/user":hdfs:supergroup:dr,,,"and so on,why?who can help me?
Created 01-16-2014 07:04 AM
Created 01-16-2014 07:04 AM
Created 10-15-2014 03:45 PM
I had this issue too in Dev during our automated oozie sharelib creation process--which was essentially doing this:
oozie-setup sharelib create -fs hdfs://devhost:8020 -locallib /usr/lib/oozie/oozie-sharelib-yarn.tar.gz
The error I was seeing was:
org.apache.hadoop.security.AccessControlException: Permission denied: user=oozie, access=WRITE, inode="/user":hdfs:supergroup:drwxr-xr-x
It wasn't exactly clear to me at first as it seemed like a permissions error given the error above.
For me it was solved by changing the address that the service was listening on in /etc/hadoop/conf/core-sitse.xml. Mine was previously listening on "localhost:8020." (127.0.0.1)
So to be clear my fix was this:
<configuration>
<property>
<name>fs.defaultFS</name>
<value>hdfs://0.0.0.0:8020</value>
</property>
&& then bounce the service with hadoop-hdfs-namenode restart
optional: validate with netstat -tupln | grep '8020'
Hope this helps someone else out.
-cmcc
Created 01-14-2016 01:20 PM
A quick update to this thread to advise of a new Community Knowledge Article on this subject.
How to resolve "Permission denied" errors in CDH
Created 05-05-2017 11:01 PM
thank u so much!!!!
Created 11-16-2017 01:21 AM
Created 12-04-2019 04:38 AM
thanks. its worked nicely
Created 06-27-2023 01:54 PM
thanks it solved the problem
Created 06-21-2016 10:09 AM
In cloudera manager, go to hdfs configuration under advanced and put the following code in HDFS Service Configuration Safety Valve:
<property>
<name>dfs.permissions</name>
<value>false</value>
</property>
Created 06-01-2017 10:27 PM