Support Questions
Find answers, ask questions, and share your expertise

[HDP-2.3.2] Kafka 0.9 consumer version issue.

Expert Contributor

I'm on HDP-2.3.2 with kafka-0.9.0

I can produce messages using v0.8.2 and 0.9.0 okay and consume it using v0.8.2.

But when consuming messages using V.0.9.x kafka, I get this error:

Error in fetch kafka.consumer.ConsumerFetcherThread$FetchRequest@9439eee. Possible cause: java.nio.BufferUnderflowException (kafka.consumer.ConsumerFetcherThread)

Please Help.

3 REPLIES 3

Expert Contributor

Does this mean I need to add inter.broker.protocol.version and set it to 0.9.0?

Will this enable consuming messages using 0.9.x consumer client?

And what about the 0.8.2 versions?

(sorry i'm confused) thanks!

Expert Contributor

I added the inter.broker.protocol.version=0.9.0.0 (and 0.9.0)

After restarting kafka, it won't start again.

I have an error of

java.util.NoSuchElementException: key not found: 0.9.0