Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HDP 2.5.0 Install on RHEL 6.7?

Solved Go to solution

HDP 2.5.0 Install on RHEL 6.7?

New Contributor

Has anyone successfully completed an installation of HDP 2.5.0 on RHEL 6.7? The documentation says it support 6.X, but I'm getting the following error:

resource_management.core.exceptions.Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install hadoop_2_5_0_0_1245-yarn' returned 1. Error: Package: 1:cups-1.4.2-50.el6_4.5.x86_64 (rhel6)
           Requires: cups-libs = 1:1.4.2-50.el6_4.5
           Installed: 1:cups-libs-1.4.2-72.el6.i686 (@anaconda-RedHatEnterpriseLinux-201507020259.x86_64/6.7)
               cups-libs = 1:1.4.2-72.el6
           Available: 1:cups-libs-1.4.2-50.el6_4.5.i686 (rhel6)
               cups-libs = 1:1.4.2-50.el6_4.5
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

1:1.4.2-50.el6_4.5 appears to be the version which shipped with RHEL 6.5. Is there support for HDP 2.5.0 on RHEL 6.7?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: HDP 2.5.0 Install on RHEL 6.7?

New Contributor

It was my own stupid mistake. I was installing redhat dependencies from a 6.5 repository rather than 6.7. Pointed my RHEL repo to a 6.7 one and all completed perfectly. Thanks @Terry Padgett for the help.

3 REPLIES 3

Re: HDP 2.5.0 Install on RHEL 6.7?

Expert Contributor
@Eric Brosch

Can you downgrade to the earlier version with this command?

yum downgrade cups-libs-1.4.2-50.el6_4.5.i686 

Re: HDP 2.5.0 Install on RHEL 6.7?

New Contributor

It was my own stupid mistake. I was installing redhat dependencies from a 6.5 repository rather than 6.7. Pointed my RHEL repo to a 6.7 one and all completed perfectly. Thanks @Terry Padgett for the help.

Re: HDP 2.5.0 Install on RHEL 6.7?

New Contributor

Hi Eric,

How did you point the RHEL repo to a different version?

Thanks!