Support Questions
Find answers, ask questions, and share your expertise

HDP 2.5 Installation problem in CentOS7

Team,

I am getting error during HDP 2.5 installation in Centos 7:

resource_management.core.exceptions.Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install snappy-devel' returned 1. Error: Package: snappy-devel-1.0.5-1.el6.x86_64 (HDP-UTILS-1.1.0.21)
           Requires: snappy(x86-64) = 1.0.5-1.el6
           Installed: snappy-1.1.0-3.el7.x86_64 (@centos7)
               snappy(x86-64) = 1.1.0-3.el7
           Available: snappy-1.0.5-1.el6.x86_64 (HDP-UTILS-1.1.0.21)
               snappy(x86-64) = 1.0.5-1.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Please suggest a solution to overcome this issue.
Sridhar



1 ACCEPTED SOLUTION

Accepted Solutions

Re: HDP 2.5 Installation problem in CentOS7

@Sridhar M

You seems to be hitting the issue that is reported in: http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.2.0/bk_ambari_troubleshooting/content/_resolving...

3.10. Problem: DataNode Fails to Install on RHEL/CentOS 7.

During cluster install, DataNode fails to install with the following error:  
resource_management.core.exceptions.
            Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install snappy-devel' returned 1.
            Error: Package: snappy-devel-1.0.5-1.el6.x86_64 (HDP-UTILS-1.1.0.20)
            Requires: snappy(x86-64) = 1.0.5-1.el6
            Installed: snappy-1.1.0-3.el7.x86_64 (@anaconda/7.1)
            snappy(x86-64) = 1.1.0-3.el7
            Available: snappy-1.0.5-1.el6.x86_64 (HDP-UTILS-1.1.0.20)
            snappy(x86-64) = 1.0.5-1.el6

 3.10.1. Solution:

 Hadoop requires the snappy-devel package that is a lower version that what is on
              the machine already.  Run the following on the host and retry.
yum remove snappy
yum install snappy-devel

.

View solution in original post

5 REPLIES 5

Re: HDP 2.5 Installation problem in CentOS7

why installation engine is checking el6 rpm rather than el7 rpm?

Re: HDP 2.5 Installation problem in CentOS7

@Sridhar M

You seems to be hitting the issue that is reported in: http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.2.0/bk_ambari_troubleshooting/content/_resolving...

3.10. Problem: DataNode Fails to Install on RHEL/CentOS 7.

During cluster install, DataNode fails to install with the following error:  
resource_management.core.exceptions.
            Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install snappy-devel' returned 1.
            Error: Package: snappy-devel-1.0.5-1.el6.x86_64 (HDP-UTILS-1.1.0.20)
            Requires: snappy(x86-64) = 1.0.5-1.el6
            Installed: snappy-1.1.0-3.el7.x86_64 (@anaconda/7.1)
            snappy(x86-64) = 1.1.0-3.el7
            Available: snappy-1.0.5-1.el6.x86_64 (HDP-UTILS-1.1.0.20)
            snappy(x86-64) = 1.0.5-1.el6

 3.10.1. Solution:

 Hadoop requires the snappy-devel package that is a lower version that what is on
              the machine already.  Run the following on the host and retry.
yum remove snappy
yum install snappy-devel

.

View solution in original post

Re: HDP 2.5 Installation problem in CentOS7

In General:

This seems to be because of incorrect version of snappy-devel On CentOS7/Redhat7. So as a workaround you will need to try the following:

yum remove -y snappy 
yum install -y snappy-devel

.

Re: HDP 2.5 Installation problem in CentOS7

Super Guru

I installed HDP 2.5 on Centos 7.2 with no issues, make sure it's the correct repo and follow the prereqs for install

Re: HDP 2.5 Installation problem in CentOS7

resolved my issue by removing snappy as suggested by JSS