Support Questions
Find answers, ask questions, and share your expertise

HDP 2.5 Sandbox not starting

Super Collaborator

Hi,

Today I downloaded the Sandbox from http://hortonworks.com/downloads/#sandbox When I start it though it seems like some but not all components are launched. First the Virtualbox screen is stuck in this mode:

7851-screen-shot-2016-09-21-at-94723-pm.png

When you hit a button I get more info:

7852-screen-shot-2016-09-21-at-94624-pm.png

The time counter just runs forever. By this time the Ambari login screen is up and the YARN app WebUI on 8088 as well, but that is it. It is stuck on start up. What is going on?

UPDATE

7892-screen-shot-2016-09-22-at-71256-am.png

After 36 minutes it it still doing something

1 ACCEPTED SOLUTION

Super Collaborator

Well, I turned to the Docker version instead. That one is working!

View solution in original post

33 REPLIES 33

New Contributor

I am also facing the same problem. But I soved it by deleting the virtual box logs which is located at

c:/users/' your pcname'/.VirtualBox (for windows users only)

Delete only those files which have names like 'VBoxSVC.log' .Remember to do this step only when your virtualbox is closed.

Explorer

I tried to start the sandbox (HDP 2.6, 8 GB assigned) on a Core i7 with 16 GB RAM. Booting is not finished after more than 30 hours (CPU is very busy). Free RAM is available, according to the task manager VirtualBox is using about 124 MB of RAM only. Is there anything I could do?

Explorer

The problem is virtualbox. With vmware everything is working as expected.

New Contributor

I am running HDP version 2.6.1 on VMware.

Initially it starts up fine, but any of my attempts to shutdown the "docker" container for the sandox gracefully failed, and just shutting down the host VM via the VMware Player window resulted in the SandboxContainer startup hanging at the next startup.

Sending shutdown commands to the docker OS (NOT to the host VM OS) via SSH does not work because of some permission issues.

I ended up starting up the VM initially and never shutting it down, only suspending. Will stick with this workaround until I stumble upon a way to shutdown the sandbox containter gracefully and only THEN shutting down the host VM.

I miss the days when the sandbox was running on just a plain VM instead of this VM+docker combo. You can't even see what happens when the docker is being started...

New Contributor

Same problem here. I am running the HDP sandbox 2.6.1 on VirtualBox 5.1.26 on a Centos 7 host. The VM never finishes booting. see attached screen shot. After about 10 minutes it is still starting the sandbox container (hdp1.png), and after 3 days it is stuck between cleaning up temporary directories and network manager script dispatcher (hdp2.png).


New Contributor

Any ideas? I have the same problem with Oracle VB

New Contributor

Same issue with vmware HDPsandbox 2.6.1 hdpsandbox261vmwarefailed.png

New Contributor

@Paul Hodor, just ignore the message and type in

http://127.0.0.1:8080 rather than http://127.0.0.1:8888 in your browser; it should bring up the Ambari UI

HTH,

Akshaya

,

@Paul Hodor just ignore the message and type in

http://127.0.0.1:8080 rather than http://127.0.0.1:8888 in your browser; it should bring up the Ambari UI

Explorer

Akshaya Nat if i do what you suggested alot of the hadoop components dont work for example hbase so im not sure its helpfull

New Contributor

If you see "Starting SandboxContainer.." then you're already up and running. Just navigate to http://127.0.0.1:8080/ on your host machine and the Ambari login screen should pop up.

The default admin login is raj_ops/raj_ops

,

If you see "Starting SandboxContainer..." then it's already up and running.

Just navigate to http://127.0.0.1:8080/ in your host machine browser and you should see the login screen.

Default login is raj_ops/raj_ops

New Contributor

I am able to start the Sandbox on Windows 10 and Oracle VirtualBox.

Initially I also faced same problem, Sanbox was not starting even after setting RAM to 12GB. (waited for more than 1 hour)

So I removed the sandbox image from VirtualBox, closed the virtualbox application, used Ccleaner to clean temp files, and restarted windows .

After restart I reloaded the sandbox image in VirtualBox and set the RAM to 11111 (close to 11GB).

and then closed VirtualBox application, used Ccleaner to clean temp files, and restarted windows again.

after that sandbox did work, It did took some time to start up.

After that I also tried running it with 10GB RAM but did not worked.

Still wonder why it did not worked with 12GB RAM, but worked later with close to 11GB,

My suspect is something to do with temp files , May be I am wrong. I am not sure.

But give it a try and see if that works for you.

New Contributor

I have resolved this issue by switch off name node safe mode to off(leave).

Open SSH using root login and run below command.

> sudo -u hdfs hdfs dfsadmin -safemode leave

you will get "Safe mode is OFF" message. Now try to start services.

New Contributor

Hello All ,


Newbie and learning.


sandbox seems to stuck at the following .


00:00:09.966414 GIM: KVM: VCPU 0: Enabled system-time struct. at 0x0000000002722000 - u32TscScale=0xcd20cfc1 i8TscShift=-1 uVersion=2 fFlags=0x1 uTsc=0x2a3bff811 uVirtNanoTS=0x10eb9c43d

00:00:09.966475 TM: Host/VM is not suitable for using TSC mode 'RealTscOffset', request to change TSC mode ignored

00:00:12.234594 GIM: KVM: Enabled wall-clock struct. at 0x0000000002721008 - u32Sec=1561631780 u32Nano=946977500 uVersion=2

00:00:12.238143 GUI: UIFrameBufferPrivate::performResize: Size=720x400, Using fallback buffer since no source bitmap is provided

00:00:12.363769 PIT: mode=2 count=0x4a9 (1193) - 1000.15 Hz (ch=0)

00:31:50.924499 NAT: Old socket recv size: 64KB

00:31:50.924620 NAT: Old socket send size: 64KB


Also, there seems to be a following error

00:00:04.874822 NAT: Failed to redirect TCP 127.0.0.1:8005 -> 0.0.0.0:8005 (Unknown error)


tried to open 127.0.0.1 and no luck


please advise. have 16gm on a windows 10 machine .

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.