Support Questions
Find answers, ask questions, and share your expertise

HDP 2.6 requires libtirpc-devel

Rising Star

Hello,

I am trying to install HDP 2.6 on RHEL 7.2 ppc64le. Installation over ambari fails due to

"Error: Package: hadoop_2_6_0_3_8-hdfs-2.7.3.2.6.0.3-8.ppc64le (HDP-2.6) Requires: libtirpc-devel" error.

1 ACCEPTED SOLUTION

Accepted Solutions

Super Mentor

@Mustafa Kemal MAYUK

Yes, the "libtirpc-devel" package is needed by HDP 2.6. You will need to install that package from your OS Base repo.

You can see that this package is available in OS base repo. For example in my case centos7

# yum whatprovides libtirpc-devel
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
libtirpc-devel-0.2.4-0.8.el7.i686 : Development files for the libtirpc library
Repo        : base

libtirpc-devel-0.2.4-0.8.el7.x86_64 : Development files for the libtirpc library
Repo        : base

libtirpc-devel-0.2.4-0.8.el7_3.i686 : Development files for the libtirpc library
Repo        : updates

libtirpc-devel-0.2.4-0.8.el7_3.x86_64 : Development files for the libtirpc library
Repo        : updates

libtirpc-devel-0.2.4-0.8.el7_3.x86_64 : Development files for the libtirpc library
Repo        : @updates

# cat /etc/redhat-release 
CentOS Linux release 7.0.1406 (Core) 

.

View solution in original post

12 REPLIES 12

Super Mentor

@Mustafa Kemal MAYUK

Yes, the "libtirpc-devel" package is needed by HDP 2.6. You will need to install that package from your OS Base repo.

You can see that this package is available in OS base repo. For example in my case centos7

# yum whatprovides libtirpc-devel
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
libtirpc-devel-0.2.4-0.8.el7.i686 : Development files for the libtirpc library
Repo        : base

libtirpc-devel-0.2.4-0.8.el7.x86_64 : Development files for the libtirpc library
Repo        : base

libtirpc-devel-0.2.4-0.8.el7_3.i686 : Development files for the libtirpc library
Repo        : updates

libtirpc-devel-0.2.4-0.8.el7_3.x86_64 : Development files for the libtirpc library
Repo        : updates

libtirpc-devel-0.2.4-0.8.el7_3.x86_64 : Development files for the libtirpc library
Repo        : @updates

# cat /etc/redhat-release 
CentOS Linux release 7.0.1406 (Core) 

.

View solution in original post

Super Mentor

@Mustafa Kemal MAYUK

For similar discussion on this please refer to: https://community.hortonworks.com/questions/96763/hdp-26-ambari-install-fails-on-rhel-7-on-libtirpc....

If you are using RHEL7 then you might have to enable the "*-rhel-server-optional" packages.

Please see: https://access.redhat.com/solutions/265523

I had the similar problem on RHL7 and HDP2.6 using Ambari2.5. after making below change, the installation progressed. Thanks for the tip!!!!

I enabled 2 optional RHL7 OS packages by running below commands on all nodes.

subscription-manager repos --enable=rhel-7-server-optional-rpms

subscription-manager repos --enable=rhel-7-server-eus-optional-rpms

Expert Contributor

wget //ftp.icm.edu.pl/vol/rzm6/linux-slc/centos/7.1.1503/updates/x86_64/Packages/libtirpc-devel-0.2.4-0.8.el7_3.x86_64.rpm

yum install libtirpc-devel-0.2.4-0.8.el7_3.x86_64.rpm -y

This will resolve the issue. We have to do this on all the hosts


Expert Contributor

I have encountered same issue while adding back ex-data node into HDP 2.6 cluster.

Since I have no internet connection I have solved it the following way:

1. Download libtirpc-devel-0.2.4-0.10.el7.x86_64.rpm

from

libtirpc-devel

2. yum install libtirpc-devel-0.2.4-0.10.el7.x86_64.rpm

Contributor

Thanks!!!!!!!

wget -nv https://rpmfind.net/linux/centos/7.4.1708/os/x86_64/Packages/libtirpc-devel-0.2.4-0.10.el7.x86_64.rp...
yum install libtirpc-devel-0.2.4-0.10.el7.x86_64.rpm -y --skip-broken

Contributor

enabling subscription-manager repos and downloading the rpm . still have dependencies issues

[root@phcv-dlhadoop01 ~]# yum install libtirpc-devel-0.2.4-0.10.el7.x86_64.rpm -y --skip-broken

Loaded plugins: product-id, rhnplugin, search-disabled-repos, subscription-manager
This system is receiving updates from RHN Classic or Red Hat Satellite.
Examining libtirpc-devel-0.2.4-0.10.el7.x86_64.rpm: libtirpc-devel-0.2.4-0.10.el7.x86_64
Marking libtirpc-devel-0.2.4-0.10.el7.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package libtirpc-devel.x86_64 0:0.2.4-0.10.el7 will be installed
--> Processing Dependency: libtirpc = 0.2.4-0.10.el7 for package: libtirpc-devel-0.2.4-0.10.el7.x86_64

Packages skipped because of dependency problems:
libtirpc-devel-0.2.4-0.10.el7.x86_64 from /libtirpc-devel-0.2.4-0.10.el7.x86_64

Contributor

Contributor

Thanks!!!!!!!

wget -nv https://rpmfind.net/linux/centos/7.4.1708/os/x86_64/Packages/libtirpc-devel-0.2.4-0.10.el7.x86_64.rp...
yum install libtirpc-devel-0.2.4-0.10.el7.x86_64.rpm -y --skip-broken