Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HDP 2.6 with centos 7.6

Highlighted

HDP 2.6 with centos 7.6

New Contributor

Hi,


I share a feedback about HDP 2.6 with centos 7.6.

We have a cluster based on HDP 2.6.4. We added news nodes that are now systematically installed under centos 7.6 version. In that configuration, ambari-agent can not connect to the server and raises the following error in ambari-agent.log:

INFO 2019-02-15 14:25:45,083 NetUtil.py:70 - Connecting to https://xhdpbackgtw02u.hadoop:8440/ca
ERROR 2019-02-15 14:25:45,085 NetUtil.py:96 - EOF occurred in violation of protocol (_ssl.c:618)
ERROR 2019-02-15 14:25:45,085 NetUtil.py:97 - SSLError: Failed to connect. Please check openssl library versions.
Refer to: https://bugzilla.redhat.com/show_bug.cgi?id=1022468 for more details.
WARNING 2019-02-15 14:25:45,085 NetUtil.py:124 - Server at https://xhdpbackgtw02u.hadoop:8440 is not reachable, sleeping for 10 seconds...


The root cause is NetUtil.py that fails for unkown reason. It seems to work if you download Python packages to centos 7.5 ones.

We also tried to upgrade ambari-agent to 2.6.2.2 that is certified under centos 7.6 but with the same result. Definitively ambari-agent don't seem to work with Python 2.7.5-76.

Good luck...

1 REPLY 1

Re: HDP 2.6 with centos 7.6

Super Mentor

@easyoups

Basically the error is :

ERROR 2019-02-15 14:25:45,085 NetUtil.py:96 - EOF occurred in violation of protocol (_ssl.c:618)

.

This error cause is explained in detail in the following Article: https://community.hortonworks.com/articles/188269/javapython-updates-and-ambari-agent-tls-settings.h...

To solve this problem simply configure the Ambari Agent to use TLSv1.2 when communicating with the Ambari Server by editing each Ambari Agent’s /etc/ambari-agent/conf/ambari-agent.ini file and adding the following configuration property to the security section:

[security] force_https_protocol=PROTOCOL_TLSv1_2

Once this configuration change has been made, the Ambari Agent needs to be restarted. After restarting you should no longer see the ERROR’s in the Ambari Agent logs, and in the Ambari Server UI you’ll notice that all Ambari Agents are once again heartbeating.