Support Questions
Find answers, ask questions, and share your expertise

HDP 3.0 "ip addr show" shows only eth0 and lo

Contributor

Hi,

Need help here:

When I am doing "ip addr show" in HDP 3.0 shell in box; it is showing only eth0 and lo. Though in NETWORK options I have two network adapters

1) NAT

2) NETNETWORK


In my VirtualBox NET NETWORK setting I have given NETNETWORK 11.0.2.0/24.

My concern is when I am doing ip addr show my NETNETWORK ip 11.0.2.# should be displayed, which is not displaying currently.


Do I need to have some setting changes in HDP 3.0. Or HDP 3.0 doesn't sense network adapter other than NAT?

1 ACCEPTED SOLUTION

Mentor

@Shashank Naresh

What do you mean by choosing only network adapter? There are different adapter al are network adaoters can you elaborate


109373-network.png


network.png

View solution in original post

3 REPLIES 3

Mentor

@Shashank Naresh

I guess your problem is with the network configuration. Adapter 1 should be NAT, Adapter 2 should either Wireless or LAN in my example screenshot its Realtek PCIe GBE Family controller the LAN NIC for my laptop yours could be different.

See attached screenshot

After saving the configuration restart the Virtual box

Please revert

Naresh.PNG

Contributor

I was able to do it by choosing only network adapter setting.

Mentor

@Shashank Naresh

What do you mean by choosing only network adapter? There are different adapter al are network adaoters can you elaborate


109373-network.png


network.png
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.