Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HDP 3.0 "ip addr show" shows only eth0 and lo

Solved Go to solution
Highlighted

HDP 3.0 "ip addr show" shows only eth0 and lo

Hi,

Need help here:

When I am doing "ip addr show" in HDP 3.0 shell in box; it is showing only eth0 and lo. Though in NETWORK options I have two network adapters

1) NAT

2) NETNETWORK


In my VirtualBox NET NETWORK setting I have given NETNETWORK 11.0.2.0/24.

My concern is when I am doing ip addr show my NETNETWORK ip 11.0.2.# should be displayed, which is not displaying currently.


Do I need to have some setting changes in HDP 3.0. Or HDP 3.0 doesn't sense network adapter other than NAT?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: HDP 3.0 "ip addr show" shows only eth0 and lo

Mentor

@Shashank Naresh

What do you mean by choosing only network adapter? There are different adapter al are network adaoters can you elaborate


109373-network.png


network.png
3 REPLIES 3

Re: HDP 3.0 "ip addr show" shows only eth0 and lo

Mentor

@Shashank Naresh

I guess your problem is with the network configuration. Adapter 1 should be NAT, Adapter 2 should either Wireless or LAN in my example screenshot its Realtek PCIe GBE Family controller the LAN NIC for my laptop yours could be different.

See attached screenshot

After saving the configuration restart the Virtual box

Please revert

Naresh.PNG

Re: HDP 3.0 "ip addr show" shows only eth0 and lo

I was able to do it by choosing only network adapter setting.

Re: HDP 3.0 "ip addr show" shows only eth0 and lo

Mentor

@Shashank Naresh

What do you mean by choosing only network adapter? There are different adapter al are network adaoters can you elaborate


109373-network.png


network.png