Support Questions
Find answers, ask questions, and share your expertise

HMaster deamon is not runnig after Hbase starts

HMaster deamon is not runnig after Hbase starts

Explorer

I installed Hbase and start the Hbase. But when i check the runn deamons using "sudo jps" it shoes me only below.

aruna@aruna:~/hbase-1.2.4$ sudo jps
[sudo] password for aruna: 
6722 HRegionServer
6525 HQuorumPeer
6975 Jps

1) When installing i added below to the site.xml file

<property>
<name>hbase.rootdir</name>
<value>/home/aruna/hbase-1.2.4/hbasestorage</value>
</property>

<property>
<name>hbase.zookeeper.quorum</name>
<value>localhost</value>
</property>

<property>
<name>hbase.cluster.distributed</name>
<value>true</value>
</property>

<property>
<name>hbase.zookeeper.property.dataDir</name>
<value>/home/aruna/hbase-1.2.4/hbasestorage/zookeeper</value>
</property>

<property>
<name>hbase.zookeeper.property.clientPort</name>
<value>2181</value>
</property>

2) I added below to the file

 export JAVA_HOME=/usr/lib/jvm/java-7-oracle
 export HBASE_MANAGES_ZK=true

I starts the Hbase using below command.

./bin/start-hbase.sh 

I don't know why its not running HMaster deamon?

4 REPLIES 4

Re: HMaster deamon is not runnig after Hbase starts

Super Guru

@Aruna Sameera

Did you install HBase on top of local file system? If not, then if its running on HDFS, then do you have /home/aruna/hbase-1.2.4/hbasestorage in your HDFS? Usually HBase runs on HDFS and the location for root directory is /hbase or /hbase/data

Re: HMaster deamon is not runnig after Hbase starts

@Aruna Sameera

I'm guessing that it's port issue

Can you provide error message from hbase logs?

Re: HMaster deamon is not runnig after Hbase starts

Super Collaborator

Can you check master log for the exception (it usually located at /var/log/hbase or $HBASE_HOME/logs, depending on the way you installed HBase). It usually quite easy to understand why the service was stopped.

Re: HMaster deamon is not runnig after Hbase starts

If you check the log for hbase as said by Sergey Soldatov, you may find the problem as connection refused due to mismatch in the port for the master. you can check it in the site http://wiki.apache.org/hadoop/ConnectionRefused, as mentioned in the log file, this might help