Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

HUE not showing databases or tables

HUE not showing databases or tables

Contributor

 

Weird anomoly on HUE

I have a instance using chrome hitting the same HUE instance on the same cluster

 

in 1 tab I can run Impala queries but newer tabs cannot run any queries

 

Chrome  Version 47.0.2526.73 (64-bit)

CDH 5.3.3 

Sentry is not enabled

 

 

Screen Shot 2015-12-04 at 10.23.14 AM.png

 

 

4 REPLIES 4
Highlighted

Re: HUE not showing databases or tables

Could you type:

invalidate metadata

in the query editor?

And click on the refresh table icon in the assist

Romain

Re: HUE not showing databases or tables

Contributor
did all of the above in the query editor
also checked firewalls (no changes)
restarted Impala and HUE
have not restarted Hive / Beeswax yet

Re: HUE not showing databases or tables

New Contributor

It may be a caching issue. So try changing the browser.
Like in my case it was working with hive but not with impala. Also i had disable the kerberos.


It may happen sometime when the kerberos is disabled from the cluster. So ensure following properties are changed on cloudera manager.

Zookeeper

enableSecurity (Enable Kerberos Authentication) FALSE

 

HDFS
hadoop.security.authentication: Simple
hadoop.security.authorization: FALSE
dfs.datanode.address from 1004 (for Kerberos) to 50010 (default)
dfs.datanode.http.address from 1006 (for Kerberos) to 50075 (default)
Data Directory Permissions from 700 to 755

HBASE

hbase.security.authentication: Simple
hbase.security.authorization: FALSE

 

Hue

Kerberos Ticket Renewer: Delete role or stop role

 

Kafka

kerberos.auth.enable: FALSE

 

Key-Value

hbaseindexer.authentication.type: FALSE

 

SOLR

olr Secure Authentication: Simple


Once Done. Try again same steps . else switch the browser, for eg change the browser to FireFox from chrome and try again. 

 

 

Re: HUE not showing databases or tables

New Contributor
For issue : Hue not showing hbase tables, we needs to give grant privilage to hue user in hbase shell.
take kerberos authentication using hbase keytab. then start hbase shell & use below command.
grant 'hue', 'RWXC'

Now you will find that hbase tables are showing in hue. same process is for hive also.