Support Questions
Find answers, ask questions, and share your expertise

Hadoop Service - Metrics Collector failing when installing without Internet

New Contributor

I'm getting an error while setting up HDP-Services.

I'm doing it without Internet and I have setup a local repository on the same machine itself.

I used a tar file and saved it on the same server itself and accessed it using file:///

Somehow it is still trying to install from internet.

Please Help



Super Mentor

@Ram Krishnan

Please try this:

1. Navigate inside the "/etc/yum.repos.d/" directory in terminal.

# cd /etc/yum.repos.d/

2. Search for files which has "" listed inside it.

# gret ''  /etc/yum.repos.d/*


3. You might find some files like which has the mentioned URL and then add "enabled=0" to disable that repo. Something like following or comment out the mirror list.

name=CentOS-$releasever - Base

In order to know more about how to disable a yum repo please refer to:



4. Perform yum clean

# yum clean all


then try again.

New Contributor

Thanks @Jay Kumar SenSharma!

This worked.

So I am setting up a cluster without the internet. During the Services Install and start step, the installer is still trying to access the internet. It tries to 'yum install' a package as it is not there. For example, python-devel,gcc,mysql-server etc were some packages that it tried to install and failed because internet is not available.

My HDP repositories have all been setup on local itself.

Is this a problem with my CentOS local repository. If yes, how do I maintain an updated repository.

Is there access to a list of packages that the HDP-Services would be installing. This would help account for the packages that are required.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.