Support Questions
Find answers, ask questions, and share your expertise

Hadoop datanode jmx metrics pages

Rising Star

Hi,

Is jmx info pages of datanodes deprecated?

I remember like there used to be pages on http:<datanode>:50070/

I also see similar tips on this page for datanode (50075):

https://www.datadoghq.com/blog/collecting-hadoop-metrics/

On HDP 2.5.3 I can't see them. Do I remember wrong?

Is it something I can enable-disable?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Hadoop datanode jmx metrics pages

These pages are still present. You can navigate to the jmx servlet on the DataNode web UI.

e.g. http://<datanode>:50075/jmx

View solution in original post

4 REPLIES 4

Re: Hadoop datanode jmx metrics pages

These pages are still present. You can navigate to the jmx servlet on the DataNode web UI.

e.g. http://<datanode>:50075/jmx

View solution in original post

Re: Hadoop datanode jmx metrics pages

Rising Star

Hi @Arpit Agarwal,

Thank you for your answer.

Actually, you are right. I checked that by a friend's installation and page is there.

Unfortunately that URL is not available in my environment.

This site can’t be reached

10.0.109.23 refused to connect.

ERR_CONNECTION_REFUSED

I realised an anormal situation on my environment.

I got two datanode instances running (Dproc_datanode) one started by root and other by hdfs.

It should be hdfs so I killed the one started by root. Expected to see the page but it wasn't there. I checked the service on Ambari but it seems like Ambari manages the process started by root : It was stopped.

I need to investigate more what is going on :/

Re: Hadoop datanode jmx metrics pages

You likely have Kerberos enabled. The DataNode process starts as root so it can bind a privileged port (<1024) for data transfer. Then it launches another process as user hdfs. You should not kill either process.

The "refused to connect" error looks like some network connectivity issue in your environment, or you are hitting the wrong port number. See if you can find the correct info port from either configuration or from the DataNodes tab of the NameNode web UI.

Re: Hadoop datanode jmx metrics pages

Rising Star

Answer appeared on second comment.

Thanks @Arpit Agarwal !

By the way, port number is 1022

On /etc/hadoop/conf/hdfs-site.xml file

<property>

<name>dfs.datanode.http.address</name>

<value>0.0.0.0:1022</value>

</property>

Yes, my environment is Kerberos enabled.

It was already represented on Namenode UI > Datanodes tab > "Http Address" column.