Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

Hbase Copy table fails for 250 Million Records from a HDP 2.2 ==> HDP 2.4 cluster. Please assist.

Contributor
Error: org.apache.hadoop.hbase.client.ScannerTimeoutException: 70218ms passed since the last invocation, timeout is currently set to 60000 at org.apache.hadoop.hbase.client.ClientScanner.loadCache(ClientScanner.java:434) at org.apache.hadoop.hbase.client.ClientScanner.next(ClientScanner.java:364) at org.apache.hadoop.hbase.mapreduce.TableRecordReaderImpl.nextKeyValue(TableRecordReaderImpl.java:205) at org.apache.hadoop.hbase.mapreduce.TableRecordReader.nextKeyValue(TableRecordReader.java:147) at org.apache.hadoop.hbase.mapreduce.TableInputFormatBase$1.nextKeyValue(TableInputFormatBase.java:216) at org.apache.hadoop.mapred.MapTask$NewTrackingRecordReader.nextKeyValue(MapTask.java:556) at org.apache.hadoop.mapreduce.task.MapContextImpl.nextKeyValue(MapContextImpl.java:80) at org.apache.hadoop.mapreduce.lib.map.WrappedMapper$Context.nextKeyValue(WrappedMapper.java:91) at org.apache.hadoop.mapreduce.Mapper.run(Mapper.java:145) at org.apache.hadoop.mapred.MapTask.runNewMapper(MapTask.java:787) at
1 ACCEPTED SOLUTION

Super Collaborator

Default was used.

Please bump it to 90 seconds or higher.

View solution in original post

6 REPLIES 6

Super Collaborator

Please increase the value for the following parameter:

<name>hbase.client.scanner.timeout.period</name> <value>60000</value>

Contributor

@Ted Yu Error message shows 60 seconds as default. Do we need to bump it to 90 seconds? thats what you mean? I dont see this property currently set so I guess its taking from default. Please confirm.

Super Collaborator

Please also check region servers to see if there was critical error during the copy.

Contributor

@Ted Yu Region servers are good.

Super Collaborator

Default was used.

Please bump it to 90 seconds or higher.

Contributor

@Ted Yu Thanks it worked.