Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Hive 2.0 isn't visible in Ambari

Solved Go to solution

Hive 2.0 isn't visible in Ambari

New Contributor

Hello,

I installed sandbox on Mac, and don't see any option to select Hive 2.0 view. Did i miss any configuration?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Hive 2.0 isn't visible in Ambari

Guru

@Rakesh Maheshwari

can you confirm the version of the Sandbox you downloaded. Also, can you show the screenshot if the Ambari menu including the user you are logging in with? If not admin, the user should have the view permissions assigned. With the admin user, click on the dropdown (in my screenshot, I'd click on Admin) -> Manage Ambari -> Views -> Hive -> Hive View 2.0 then scroll down to permissions and make sure the users you require are added. As always, if you find this post useful, don't forget to accept the answer, and/or upvote.

15032-ambari-views-menu.png

5 REPLIES 5

Re: Hive 2.0 isn't visible in Ambari

Guru

@Rakesh Maheshwari

can you confirm the version of the Sandbox you downloaded. Also, can you show the screenshot if the Ambari menu including the user you are logging in with? If not admin, the user should have the view permissions assigned. With the admin user, click on the dropdown (in my screenshot, I'd click on Admin) -> Manage Ambari -> Views -> Hive -> Hive View 2.0 then scroll down to permissions and make sure the users you require are added. As always, if you find this post useful, don't forget to accept the answer, and/or upvote.

15032-ambari-views-menu.png

Re: Hive 2.0 isn't visible in Ambari

New Contributor

Hi,

@Rakesh Maheshwari were you able to resolve this issue?

Even I am facing the same issue, I tried with Maria_Dev user and Raj_ops user.

I have installed HDP 2.4 on Azure. Inside Hive page Tables tab is not available.

hive-20-not-available.png

Re: Hive 2.0 isn't visible in Ambari

New Contributor

I have the same problem. Logging in as admin and navigating to

-> Manage Ambari -> Views -> Hive ->

as Rakesh suggested, I see only Hive 1.0.0 and Hive 1.5.0

Re: Hive 2.0 isn't visible in Ambari

New Contributor

This problem goes away after updating to HDP 2.6.

Highlighted

Re: Hive 2.0 isn't visible in Ambari

New Contributor

I was also facing similar problem with maria_dev user. However when I logged in with admin user, "Hive view" was visible. In order to solve this problem, try changing the role of maria_dev user to "Cluster User". This can be done by logging in with admin user. Click on "Admin" then "Manage Ambari". Click on "Manage Roles" and then change the role of "maria_dev" user.

,

I was also facing similar issue with "maria_dev" user. However with admin user user I was able to see "Hive View". After changing the role of "maria_dev" user to "Cluster User", "Hive View" was visible.