Support Questions
Find answers, ask questions, and share your expertise

Hive Client Install: RuntimeError: Failed to execute command '/usr/bin/zypper install --auto-agree-with-licenses --no-confirm mysql-client', exited with code '106', message: 'Error building the cache:

Solved Go to solution

Hive Client Install: RuntimeError: Failed to execute command '/usr/bin/zypper install --auto-agree-with-licenses --no-confirm mysql-client', exited with code '106', message: 'Error building the cache:

Explorer

Hi All, 

Downloaded ambari 2.7.0.0 from http://public-repo-1.hortonworks.com/ambari/sles12/2.x/updates/2.7.0.0/ambari.repo 

 

Downloaded the tarballs from https://docs.cloudera.com/HDPDocuments/Ambari-2.7.1.0/bk_ambari-installation/content/hdp_30_reposito...

 

Using Local Repository. Using postgresql for ambari, druid, hive, oozie, ranger and rangerkms. 

SLES 12 SP5

 

In the Install phase, i get to Hive Client Install, it fails with this error:

Traceback (most recent call last):
File "/var/lib/ambari-agent/cache/stacks/HDP/3.0/services/HIVE/package/scripts/hive_client.py", line 60, in <module>
HiveClient().execute()
File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 353, in execute
method(env)
File "/var/lib/ambari-agent/cache/stacks/HDP/3.0/services/HIVE/package/scripts/hive_client.py", line 39, in install
self.install_packages(env)
File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 836, in install_packages
retry_count=agent_stack_retry_count)
File "/usr/lib/ambari-agent/lib/resource_management/core/base.py", line 166, in __init__
self.env.run()
File "/usr/lib/ambari-agent/lib/resource_management/core/environment.py", line 160, in run
self.run_action(resource, action)
File "/usr/lib/ambari-agent/lib/resource_management/core/environment.py", line 124, in run_action
provider_action()
File "/usr/lib/ambari-agent/lib/resource_management/core/providers/packaging.py", line 30, in action_install
self._pkg_manager.install_package(package_name, self.__create_context())
File "/usr/lib/ambari-agent/lib/ambari_commons/repo_manager/zypper_manager.py", line 203, in install_package
shell.repository_manager_executor(cmd, self.properties, context)
File "/usr/lib/ambari-agent/lib/ambari_commons/shell.py", line 749, in repository_manager_executor
raise RuntimeError(message)
RuntimeError: Failed to execute command '/usr/bin/zypper install --auto-agree-with-licenses --no-confirm mysql-client', exited with code '106', message: 'Error building the cache:

[SMT-http_SAP-SDO-DEV__com:SLE-HA12-SP5-Pool|http://sap-sdo-dev..com/repo/SUSE/Products/SLE-HA/12-SP5/x86_64/product?credentials=SMT-http_SAP-SDO-DEV__com ] Valid metadata not found at specified URL

Error building the cache:

[SMT-http_SAP-SDO-DEV__com:SLE12-SP5-SAP-Pool|http://sap-sdo-dev..com/repo/SUSE/Products/SLE-SAP/12-SP5/x86_64/product?credentials=SMT-http_SAP-SDO-DEV__com ] Valid metadata not found at specified URL

Error building the cache:

[SMT-http_SAP-SDO-DEV__com:SLES12-SP5-Pool|http://sap-sdo-dev..com/repo/SUSE/Products/SLE-SERVER/12-SP5/x86_64/product?credentials=SMT-http_SAP-SDO-DEV__com ] Valid metadata not found at specified URL

Some of the repositories have not been refreshed because of an error.

 

when i zypper install mysql-client:

Loading repository data...
Reading installed packages...
'mysql-client' not found in package names. Trying capabilities.
'mysql-community-client' providing 'mysql-client' is already installed.
Resolving package dependencies...

Nothing to do.

 

Tried to rety, same issue. 

Edited the metadata.xml from /var/lib/ambari-agent/cache/stacks/HDP/3.0/services/HIVE  and /var/lib/ambari-server/resources/common-services/HIVE/0.12.0.2.0 to remove any mysql 

 

same issue. 

 

Not sure what else to do, at first i used mysql as the db for ambari, , druid, hive, oozie, ranger and rangerkms but got the error above, so i uninstalled mysql, and installed postgresql 12.But there is a config file somewhere that wants to install mysql-client and it won't let me get past this step without installing it. 

 

Thanks in advance.

 

Cheers,

Chris

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Hive Client Install: RuntimeError: Failed to execute command '/usr/bin/zypper install --auto-agree-with-licenses --no-confirm mysql-client', exited with code '106', message: 'Error building the cache:

Explorer

Fix was to un-install the community version and put the old version on. 

View solution in original post

3 REPLIES 3
Highlighted

Re: Hive Client Install: RuntimeError: Failed to execute command '/usr/bin/zypper install --auto-agree-with-licenses --no-confirm mysql-client', exited with code '106', message: 'Error building the cache:

Explorer

Install ambari 2.7.4 with HDP 3.1. Same error on Hive Client Install:

 

Traceback (most recent call last):
File "/var/lib/ambari-agent/cache/stacks/HDP/3.0/services/HIVE/package/scripts/hive_client.py", line 60, in <module>
HiveClient().execute()
File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 352, in execute
method(env)
File "/var/lib/ambari-agent/cache/stacks/HDP/3.0/services/HIVE/package/scripts/hive_client.py", line 39, in install
self.install_packages(env)
File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 849, in install_packages
retry_count=agent_stack_retry_count)
File "/usr/lib/ambari-agent/lib/resource_management/core/base.py", line 166, in __init__
self.env.run()
File "/usr/lib/ambari-agent/lib/resource_management/core/environment.py", line 160, in run
self.run_action(resource, action)
File "/usr/lib/ambari-agent/lib/resource_management/core/environment.py", line 124, in run_action
provider_action()
File "/usr/lib/ambari-agent/lib/resource_management/core/providers/packaging.py", line 30, in action_install
self._pkg_manager.install_package(package_name, self.__create_context())
File "/usr/lib/ambari-agent/lib/ambari_commons/repo_manager/zypper_manager.py", line 203, in install_package
shell.repository_manager_executor(cmd, self.properties, context)
File "/usr/lib/ambari-agent/lib/ambari_commons/shell.py", line 753, in repository_manager_executor
raise RuntimeError(message)
RuntimeError: Failed to execute command '/usr/bin/zypper install --auto-agree-with-licenses --no-confirm mysql-client', exited with code '106', message: 'Error building the cache:

[SMT-http_SAP-SDO-DEV__com:SLE-HA12-SP5-Pool|http://sap-sdo-dev..com/repo/SUSE/Products/SLE-HA/12-SP5/x86_64/product?credentials=SMT-http_SAP-SDO...] Valid metadata not found at specified URL

Error building the cache:

[SMT-http_SAP-SDO-DEV__com:SLE12-SP5-SAP-Pool|http://sap-sdo-dev..com/repo/SUSE/Products/SLE-SAP/12-SP5/x86_64/product?credentials=SMT-http_SAP-SD...] Valid metadata not found at specified URL

Error building the cache:

[SMT-http_SAP-SDO-DEV__com:SLES12-SP5-Pool|http://sap-sdo-dev..com/repo/SUSE/Products/SLE-SERVER/12-SP5/x86_64/product?credentials=SMT-http_SAP...] Valid metadata not found at specified URL

Some of the repositories have not been refreshed because of an error.

Highlighted

Re: Hive Client Install: RuntimeError: Failed to execute command '/usr/bin/zypper install --auto-agree-with-licenses --no-confirm mysql-client', exited with code '106', message: 'Error building the cache:

Explorer

Tried to download the mysql-client libraries. But got this message:

 

sap-hdp-dev:/install # rpm -i mysql-client-5.6.23-2-omv2015.0.x86_64.rpm
warning: mysql-client-5.6.23-2-omv2015.0.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID bf81de15: NOKEY
error: Failed dependencies:
mysql-client < 8.0.20-1.sles12 is obsoleted by (installed) mysql-community-client-8.0.20-1.sles12.x86_64

 

Does anyone know where is the install folder i can change the pointer from mysql-client to  mysql-community-client? Or not use mysql at all. SInce my install doesn't even use mysql. 

 

As stated above,  There has to be a dependency i'm missing when trying to install.

 

Thanks again in advance.

 

Cheer,s
Chris

Highlighted

Re: Hive Client Install: RuntimeError: Failed to execute command '/usr/bin/zypper install --auto-agree-with-licenses --no-confirm mysql-client', exited with code '106', message: 'Error building the cache:

Explorer

Fix was to un-install the community version and put the old version on. 

View solution in original post

Don't have an account?