Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Hive Gateways - cannot change status to running (from none)

Solved Go to solution

Hive Gateways - cannot change status to running (from none)

Champion Alumni

Hello,

 

I'm having a 7 instances cluster and I'm using CHD5.

My problem is that I cannot manage to start the hive gateways. When I do start to hive, the gateways don't start. If I want to start them afterwards they are saying to stop hiveserver and hivemetastore. ..so I'm in a no-ending loop.

 

Hive Metastore Server
HiveServer2
Gateway

 

 

What should I do in order to start the gateways?

 

Thank you!

 

GHERMAN Alina
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Hive Gateways - cannot change status to running (from none)

The gateway role doesn't start or stop. It is there just to deploy client
config on the node and refresh it when the cluster is modified.

Regards,
Gautam Gopalakrishnan
2 REPLIES 2

Re: Hive Gateways - cannot change status to running (from none)

The gateway role doesn't start or stop. It is there just to deploy client
config on the node and refresh it when the cluster is modified.

Regards,
Gautam Gopalakrishnan
Highlighted

Re: Hive Gateways - cannot change status to running (from none)

New Contributor

Thank you for you ansver Gautam Gopalakrishnan. And for your question, Alina Gherman. I also thought it was a problem, when the gateway is always N/A. And tryed to fixed it, but unsuccessfully.