Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Hive Query is not running in cloudera HUE

Highlighted

Hive Query is not running in cloudera HUE

Explorer

Hi,

 

when we ran the "select *from tablename"  query in Cloudera Hive in HUE it is working fine ,but when i try to run the "select count(*) from tablename" or some other query the job is not running and it is throwing an error :

 

FAILED: Execution Error, return code 2 from org.apache.hadoop.hive.ql.exec.mr.MapRedTask

 

what is the problem here ? Normal select query is working and the query which requires map reduce is not working .

 

could anyone help us in resolving the issue.

 

 

  

3 REPLIES 3
Highlighted

Re: Hive Query is not running in cloudera HUE

Guru
@Nekkanti ,

You need to locate the failed YARN application job and its associated logs to understand why it is failing. Find the application ID and run:

If kerberized:
yarn logs -applicationId {application_id} -appOwner {username}

If unsecured:
sudo -u yarn yarn logs -applicationId {application_id}

Cheers
Eric
Highlighted

Re: Hive Query is not running in cloudera HUE

Explorer

Hi Eric,

 

Thanks for your response.

 

when i ran the below command:

sudo -u yarn yarn logs -applicationId {application_1578980062850_0002}

 

it is also throwing error:

Invalid ApplicationId specified

 

please suggest me what i need to do.

Re: Hive Query is not running in cloudera HUE

Guru
@Nekkanti,

The whole {application_id} is the placeholder, so you should run below instead:

sudo -u yarn yarn logs -applicationId application_1578980062850_0002
Don't have an account?
Coming from Hortonworks? Activate your account here