Support Questions
Find answers, ask questions, and share your expertise

Hive managed table doesn't work in with non transactional in hive 3

Explorer

I have enabled ACID transactions in Hive-3 within HDP-3 at cluster level. When i am trying to disable it on session level using below properties and creating new managed table using this (TBLPROPERTIES ('orc.compress'='ZLIB'),('transactional'='true')) table properties. It's giving below error :

set hive.optimize.index.filter=false;

set hive.txn.manager=org.apache.hadoop.hive.ql.lockmgr.DummyTxnManager ;

set hive.compactor.initiator.on=false;

set hive.compactor.worker.threads=0;

set hive.strict.managed.tables=false;

INFO : Starting task [Stage-0:DDL] in serial mode ERROR : FAILED: Execution Error, return code 1 from org.apache.hadoop.hive.ql.exec.DDLTask. MetaException(message:Table ref_edw4x_qn1useh1.dummy failed strict managed table checks due to the following reason: Table is marked as a managed table but is not transactional.) INFO : Completed executing command(queryId=hive_20181207104022_6a3478f0-9b8a-44db-a9a4-4d2ab5fe2b11); Time taken: 0.076 seconds Error: Error while processing statement: FAILED: Execution Error, return code 1 from org.apache.hadoop.hive.ql.exec.DDLTask. MetaException(message:Table ref_edw4x_qn1useh1.dummy failed strict managed table checks due to the following reason: Table is marked as a managed table but is not transactional.) (state=08S01,code=1)

3 REPLIES 3

Re: Hive managed table doesn't work in with non transactional in hive 3

Cloudera Employee

Hi @arjun more,

could you please provide step by step how to reproduce this?

Regards,

AQ

Re: Hive managed table doesn't work in with non transactional in hive 3

Explorer

Hello,

I told you that I had the same problem and make the following changes to my hive configuration.


106745-1551460267690.png

I'm still checking the performance of hive by changing these settings, but at least it lets me create tables.


regards

Re: Hive managed table doesn't work in with non transactional in hive 3

Explorer

Hello again,

I commented to you that I found something additional, apparently the configuration "hive.strict.managed.tables" is in two configuration blocks and the value of "True" must be changed to "False" in both.

I attached an image

regards

107201-1552510752109.png