Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Hive shell Issues

Hive shell Issues

New Contributor

hello,

I am getting below warning messages while trying to launch hive from the command window.

How to supress these warning messages?

hive-error.png

2 REPLIES 2

Re: Hive shell Issues

Super Guru

@dnyanesh kulkarnni

It says hive impersonation is not enabled which means your queries will run as user which is running hive process (its usually username "hive") instead of the user who submitted the query. So if you run hive shell as "dnyanesh" your query will still be run as "hive" which is a security flaw in case you want to trace down who ran what queries.

To get rid of the warning, you should enable Kerberos and then enable impersonation (impersonation will work without Kerberos also).<property>. set following property to true in hive-site.xml

  <name>hive.server2.enable.impersonation</name>
  <description>Enable user impersonation for HiveServer2</description>
  <value>true</value>
</property>

and then set following in core-site.xml

<property>
  <name>hadoop.proxyuser.hive.hosts</name>
  <value>*</value>
</property>
<property>
  <name>hadoop.proxyuser.hive.groups</name>
  <value>*</value>
</property>

remember, this will get rid of your warning but it does not improve security unless Kerberos is enabled.

Re: Hive shell Issues

New Contributor

@mqureshi : I have checked above config files, its been set as it is as you mentioned. But still getting warning messages.

Don't have an account?
Coming from Hortonworks? Activate your account here