Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Hortonworks Installation issue



I am new to Hortonworks and trying to learn it. I have installed HDP- virtualbox sandbox and it is running fine. I have a few questions:

1-I am not able to see any link on the This page gives me just the headings as Ambari, Atlas etc but doesnt have any links on it

2- How can i map the internal ip to the machine ip on my hosts file. I tried changing my Network to Ethernet Bridge, but once i do so, i am not able to open the local host also i.e

3- How can i connect to hadoop cluster.

4- Also i am trying to connect it through talend and i get the below errors


org.talend.designer.hdfsbrowse.exceptions.HadoopServerException: org.talend.designer.hdfsbrowse.exceptions.HadoopServerException: java.util.concurrent.TimeoutException at org.talend.designer.hdfsbrowse.hadoop.service.check.AbstractCheckedServiceProvider.checkService(

Resource Manager :

org.talend.designer.hdfsbrowse.exceptions.HadoopServerException: org.talend.designer.hdfsbrowse.exceptions.HadoopServerException: java.util.concurrent.ExecutionException: java.lang.reflect.InvocationTargetException at org.talend.designer.hdfsbrowse.hadoop.service.check.AbstractCheckedServiceProvider.checkService(

As i am new to and learning Hortonworks, any guidance as to how i can achive these is greatly appreciated



Hi @Sonu Singh

(Great name btw! :))

Welcome to the Hortonworks Sandbox, it is a great tool to start learning the Hortonworks platform with. I'll try to answer your questions in order.

1) I wouldn't worry too much about the splash page. If you can hit Ambari ( then you are good. The rest can be done via the web at

2) on my laptop's hosts file, I have an entry as follows: sandbox

When I need to connect to the sandbox, I just use the hostname and haven't had any issues. In fact, you should probably try ssh to your sandbox on port 2222, login as root, and change the Ambari admin password now if you haven't already done so.

ssh -p 2222

(default pw is hadoop)

then as root, run: ambari-admin-password-reset

3) Most of the tutorial work on the Sandbox can be done through Ambari, so logging into Ambari and using the occasional terminal via SSH as shown above should be all you need to connect to the cluster to get started.

4) The Sandbox uses docker internally, in addition to the vmware/virtualbox layer on your machine. This can sometimes making connecting third party tools (such as Talend) to it a bit tricky because of port forwarding issues. The port not only has to be open on your virtualbox layer, but also within the Docker host internally. See this link for a good explaination and guide on opening other ports:

For Talend specifically, there is a good picture of how to configure the Talend side here:

Original conversation here:

View solution in original post



Hi @Sonu Sahi,

Sorry for the late reply. I checked the link shared by you, but this doesn't help me ,as i am getting this issue when i try to put file on HDFS. I am able to connect through Putty and WinScp as well as through Talend, but get this error of failed to locate the Winutils when i run the Talend Job to put file on HDFS. Is their anything that comes to your mind for this error.