Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Hortonworks Sandbox HDP on docker installation fails

New Contributor

The script fails. See script output below.

Is there a log file? Am I doing something the wrong way?

OS: CentOS Linux release 7.5.1804 (Core)

Docker: 18.03.1-ce

The following might be related:

1. On a dual boot laptop (disk 1 -ssd with both OS, disk2 -SATA for data)

2. I have moved my docker directory to the disk2 (NTFS) for more space - had a write permission issue on the way solved

[liran@localhost installation]$ sh
+ registry=hortonworks
+ name=sandbox-hdp
+ version=2.6.5
+ proxyName=sandbox-proxy
+ proxyVersion=1.0
+ flavor=hdp
+ echo hdp
+ mkdir -p sandbox/proxy/conf.d
+ mkdir -p sandbox/proxy/
+ docker pull hortonworks/sandbox-hdp:2.6.5
2.6.5: Pulling from hortonworks/sandbox-hdp
9770d73ca513: Pull complete 
cbba75ae30cd: Pull complete 
283e5725c5f6: Pull complete 
1426e9ece03d: Pull complete 
4b00051fa827: Pull complete 
d09cdd825ed6: Pull complete 
dcbfe1670fa6: Pull complete 
fd78a46757f7: Pull complete 
5bad1882139b: Pull complete 
d29a62d4eb22: Pull complete 
4fb93bf04f14: Pull complete 
8827f466ab83: Pull complete 
a0fc39e77949: Pull complete 
595eabd2c628: Pull complete 
2a7fd016935e: Pull complete 
87526fe8ce7c: Pull complete 
d91a044a9aaf: Pull complete 
bbffcb08266c: Pull complete 
65c812fb262a: Pull complete 
132f30914412: Pull complete 
0f3e10681220: Pull complete 
505f5a3365a7: Pull complete 
abaff3c0f761: Pull complete 
7d75f267b911: Pull complete 
18099674493a: Pull complete 
26310ba15287: Pull complete 
635c5bfe7fc8: Pull complete 
2f80a5abf101: Pull complete 
Digest: sha256:0b34fa5cb197717828d6ffe547c23ad9b1c09f3b953e570e37f6f09809fbf3ba
Status: Downloaded newer image for hortonworks/sandbox-hdp:2.6.5
+ docker pull hortonworks/sandbox-proxy:1.0
1.0: Pulling from hortonworks/sandbox-proxy
951bdea65c93: Pull complete 
4b9047c5fbbb: Pull complete 
773156407aae: Pull complete 
d8524176841d: Pull complete 
Digest: sha256:42e4cfbcbb76af07e5d8f47a183a0d4105e65a1e7ef39fe37ab746e8b2523e9e
Status: Downloaded newer image for hortonworks/sandbox-proxy:1.0
+ '[' hdp == hdf ']'
+ '[' hdp == hdp ']'
++ docker images
++ grep hortonworks/sandbox-hdp
++ awk '{print $2}'
+ version=2.6.5
+ docker network create cda
+ docker run --privileged --name sandbox-hdp -h --network=cda -d hortonworks/sandbox-hdp:2.6.5
docker: Error response from daemon: error creating overlay mount to /mnt/win/docker/overlay/a06827a15f17aa81ec70d12a8a575c576c84ae6735e68d3b481ca5f9caafab2a-init/merged: invalid argument.
See 'docker run --help'.
+ echo ' Remove existing postgres run files. Please wait'
 Remove existing postgres run files. Please wait
+ sleep 2
+ docker exec -t sandbox-hdp sh -c 'rm -rf /var/run/postgresql/*; systemctl restart postgresql;'
Error: No such container: sandbox-hdp
+ sed s/sandbox-hdp-security/sandbox-hdp/g assets/
+ mv -f assets/ assets/
+ chmod +x assets/
+ assets/
+ uname
+ grep MINGW
+ chmod +x sandbox/proxy/
+ sandbox/proxy/
docker: Error response from daemon: error creating overlay mount to /mnt/win/docker/overlay/3599379fa1d3841ab86f2e8406c5b9df1b1bc4e86dedfdbbedeb870341a28f38-init/merged: invalid argument.
See 'docker run --help'.
[liran@localhost installation]$


New Contributor

I had a similar problem, I fixed it by:

  • Ensuring the latest version docker is installed
  • Increase the docker's Base Device Size with:
sudo dockerd --storage-opt dm.basesize=30G

[optional] Install latest sandbox by editing the sh script and adding the latest version number found here.

New Contributor

Thanks! You saved my day!

For other user who has faced the similar problem,

The new installed docker initialized with the overlay2 storage driver. (check with docker info command)

Need to stop the docker service and change the driver to device mapper (thought it's deprecated) (ref:

Then issue the command

sudo dockerd --storage-opt dm.basesize=30G

and start the docker service.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.