Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Hosts confirm failed. Installing using non root user account.

New Contributor


I have installed and setup ambari as a root user. Then I created a non root user hadoop and gave full sudo priveleges. I have setup ssh passwordless authentication on both my hosts is working fine. When I am running the launch wizard its failing. at confirm hosts with the below error message. Please advise what to do.

I also saw the topic of installing ambari agents as non root user. I tried the

Error Below

INFO:root:BootStrapping hosts ['', ''] using /usr/lib/ambari-server/lib/ambari_server cluster primary OS: redhat7 with user 'root'with ssh Port '22' sshKey File /var/run/ambari-server/bootstrap/4/sshKey password File null using tmp dir /var/run/ambari-server/bootstrap/4 ambari:; server_port: 8080; ambari version:; user_run_as: root
INFO:root:Executing parallel bootstrap
ERROR:root:ERROR: Bootstrap of host fails because previous action finished with non-zero exit code (255)
ERROR MESSAGE: Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).



@Yasin Mohammed

Just re-install ambari and a non root user and consequently launch wizard will succeed. The error is very clear the launch is bootstrapping as user root !

New Contributor


Thanks for the response. I was choosing automatic host registration on the UI. I changed it to manual and it worked.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.