Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

How can we upload a table using hive view(ambari) with comma(,) in the value of the column

I have a file with below data with 4 columns, out of it 1st column (TEXT1) is only column have data separated by comma (,) and remaining columns has no values/data.



Now, when I tried to upload the table using ambari hive view, I observed as below in preview table.

data of column 1 is spitted and is moved to other three columns because I am using field delimiter as comma (,)


instead I would like to upload the table like below:


can some one suggest me how can I achieve this.

attached the screen shot of the settings (field delimiter, escape character, quote character, Is first row header)



Please, in the UI, choose | as Field Delimiter character and , as Escape Character and you'll be fine OR use the escape character for what it is designed for by rewriting your text file:


Please note that the file upload size is limited by the /var/lib/ambary-server/resources and you'll definitely need USE permissions on 'default' as the procedure relies on 'create table as select' from an intermediate table stored in.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.