Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

How to Delete Zeppelin completely from host (HDP 3.0.1)


Hi, my Zeppelin installation has corrupted after some changes and I could not find the solution to the problem. So I tried to delete Zeppelin from Ambari UI -also I tried it by using REST API- but after delete operation, all configurations and directories which Zeppelin has seem still present.


I want to install Zeppelin on the same host which I deleted on and when I try it, Ambari just does some operations, which are not the complete installation processes, and after that Zeppelin seems installed but not working because of the corruption.


I wonder that when installing any service the first time by using Ambari, it creates required dirs, conf files and etc but why it can not do reverse operations when deleting the service? What can I perform to delete and install the same service on the same host correctly?


I had tried to delete all zeppelin dirs, confs, and files from the host and HDFS. Also, I deleted Zeppelin users from all hosts including host directories. Now Ambari still does not install Zeppelin properly. Is there a conf file like inventory I missed?


Any suggestions, please?




I found the problem. I've downloaded some .jar files to using spark with solr, and I've added them to under the /usr/hdp/x.x.x/zeppelin/lib directory.


I guess the version of downloaded jar files and servlet jar which zeppelin uses are not compatible, so I removed the jar files which I added and now I can reach the Zeppelin UI.


---btw, still I do now know how to purge completely Zeppelin or any service from Ambari. If you know that, please add a comment.

I hope it helps you.


@schnell  Glad you were able to find the remnant that blocked re-install.


Here is my SO reply, which gives some details about how to completely remove HDP and components from node filesystem...


With ambari, any service that is deleted with the UI, will still exist on the original node(s) the service was installed on. You would need to manually remove them from the node(s). This process is hard to find documentation on, but basically goes as follows:

  1. Delete the application from file system locations such as /etc/ /var/ /opt/ etc
  2. Remove user accounts/groups

You can find some more details in this blog post here which goes into some of the detail for completely removing HDP. Just follow steps for single service.


If this answer resolves your issue or allows you to move forward, please choose to ACCEPT this solution and close this topic. If you have further dialogue on this topic please comment here or feel free to private message me. If you have new questions related to your Use Case please create separate topic and feel free to tag me in your post.