Support Questions

Find answers, ask questions, and share your expertise

How to add custom types to the "create new entity" type selection dropdown in the Atlas UI?

New Contributor

I've added custom types to the Atlas type system, and these new types are visible in the Search area of the Atlas UI, but not the Create New Entity area of the Atlas UI ... is there any way to configure the Atlas UI to show the custom types to the type selection dropdown when manually creating a new entity in the Atlas UI?


Expert Contributor

@Paul Hanke

1.Add the following property in ATLAS_HOME/conf/ :



atlas.ui.editable.entity.types=* ( to list all types)

2. Restart Atlas.

3.Refresh browser cache

Now you should be able to see the custom type you created.

New Contributor

@Sharmadha Sainath

I'm using Atlas version 0.8 (with HDP version
unable to view custom types and most of the pre-defined types (specifically, to create an entity of type "Process" to get data lineage)
tried adding above configuration on /use/hdp/2.6.../atlas/conf/atlas--application-properties
after restarting atlas the properties file has been reset and still no more than few types on the dropdown list.
is this solution still valid?



Expert Contributor

@Amir Mamo

I guess you edited the atlas application properties file and restarted Atlas via Ambari.

The property shall be added via Ambari.

Add the property to Custom Atlas Application properties in Atlas Configs and start Atlas via Ambari (as suggested by stack advisor).

New Contributor

you have guessed right. works now, thanks!