Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

How to configure Nifi behind a load balancer with OpenID connect authentication?

How to configure Nifi behind a load balancer with OpenID connect authentication?

New Contributor

I have a Nifi instance behind an AWS Elastic Load Balancer. The OpenID provider (AWS Cognito) is complaining that the redirect URI s invalid. I presume the OpenID provider wants to post to the underlying node name instead of the public domain name used for the UI.

How to I tell Nifi to post to the load balancer instead of the underlying node name? I have already tried setting the proxy host name in nifi.properties but that doesn't work.

Thanks!

1 REPLY 1
Highlighted

Re: How to configure Nifi behind a load balancer with OpenID connect authentication?

New Contributor

Solved: Specify the load balancer port in the OpenID callback url. For example:

	https://www.yourdoman.com:443/nifi-api/access/oidc/callback
Don't have an account?
Coming from Hortonworks? Activate your account here