Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

How to resolve crash while loading data in Apache atlas using script?



I am setting apache atlas on EC2. When I tried command " bin/" it ask for username/password.

I provide admin/admin. It took a while and than gives this crashlog.

apache-atlas-0.9-incubating-SNAPSHOT$ bin/

Enter username for atlas :-


Enter password for atlas :-


=========Crash Log================

Exception in thread "main" java.lang.IllegalArgumentException: None of the passed URLs are active org.apache.atlas.AtlasServerEnsemble@40ef3420

at org.apache.atlas.AtlasBaseClient.determineActiveServiceURL(

at org.apache.atlas.AtlasBaseClient.initializeState(

at org.apache.atlas.AtlasBaseClient.initializeState(

at org.apache.atlas.AtlasBaseClient.<init>(

at org.apache.atlas.AtlasClientV2.<init>(

at org.apache.atlas.examples.QuickStartV2.<init>(

at org.apache.atlas.examples.QuickStartV2.runQuickstart(

at org.apache.atlas.examples.QuickStartV2.main(

Caused by: org.apache.atlas.AtlasServiceException: Metadata service API GET : api/atlas/admin/status failed

at org.apache.atlas.AtlasBaseClient.selectActiveServerAddress(

at org.apache.atlas.AtlasBaseClient.determineActiveServiceURL(

... 7 more

Caused by: java.lang.RuntimeException: Could not find any active instance

... 9 more

No sample data added to Apache Atlas Server.

Please guide If any one has any idea about it.



Hello @Nixon Rodrigues

Thanks for your help, it works with mvn clean package -Pdist,berkeley-elasticsearch

Now I am trying to load code base in eclipse and all dependencies have been resolved but in atlas-webapp.

In setup code in eclipse guide following line is mention:

a. File - Import - Maven - Existing Maven Projects b. Browse to your Atlas folder c. Uncheck the root project and non-Java projects such as dashboardv2, docs and distro, then click Finish

But if I don't import dashboardv2 in eclipse atlas-webapp gives following error:

Failed to execute goal on project atlas-webapp: Could not resolve dependencies for project org.apache.atlas:atlas-webapp:war:0.9-incubating-SNAPSHOT: Failure to find org.apache.atlas:atlas-dashboardv2:war:0.9-incubating-SNAPSHOT

Can you guide me on this?

Expert Contributor

@Naseem Rafique Good Atlas is up and working with berkeley-elasticsearch profile , hbase-solr profile also should work.

I use ideaInteliJ as IDE and do packaging from cmd line, so not aware of this eclipse issue,

I would recommend that you close this thread and open a new topic of eclipse issue where developer having good knowledge.



Hi Guys, i am trying same thing on my MAC OSX EI Capitan 10.11.3 with 8GB RAM, SSD, when i run it just says "Apache Atlas Server started!!!" no other message and then when i run script it ask for user name and password but on type creation throws an exception. for details look at screen-shot-2017-04-17-at-115554-am.png