Support Questions
Find answers, ask questions, and share your expertise

How to set “nifi.remote.input.http.enabled=true” in MiNifi config.yml

New Contributor

I can't get Site to Site working on MiNiFi (JAVA). I have enabled all security properties in the config.yml file, still the generated nifi.properties file does not include nifi.remote.input.http.enabled=true any ideas, please?

1 REPLY 1

New Contributor

Hi All,

I am still experienicing this challenge. I see this error in the Minifi logs.

2018-07-28 23:27:42,409INFO [main] o.apache.nifi.controller.FlowController Not enabling RAW Socket Site-to-Site functionality because nifi.remote.input.socket.port is not set

2018-07-28 23:27:42,409 INFO [main] o.apache.nifi.controller.FlowController Not enabling HTTP(S) Site-to-Site functionality because the 'nifi.remote.input.http.enabled' property is not true

https://xxxxxxx:9443/nifi Thread-1] o.a.n.r.util.SiteToSiteRestApiClient Failed to get controller from https://xxxx:9443/nifi-api due to javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure

am sure the ssl error is because RAW/HTTPS connection is not enabled, hence minifi is still trying to connect in an unsecured way.

Please help