Support Questions
Find answers, ask questions, and share your expertise

How to use RHEL 7 in Cloudbreak on AWS?

Contributor

Hi All,

Is there a way to use RHEL 7 custom AMI on AWS with Cloudbreak as I can currently see only Amazon Linux is being supported? Is there any way that I can use RHEL7/Centos7 on AWS using Cloudbreak?

Thanks in advance.

7 REPLIES 7

Super Collaborator

RedHat is for sure supported by AWS, and I think also with Cloudbreak. I am not using it, but here is some documentation on how to do it:

https://hortonworks.github.io/cloudbreak-documentation/latest/images/index.html

I think it also mentions that Centos 7.3 is a standard image.

Contributor

Thanks for the reply @Harald Berghoff, Yes AWS supports RHEL but i'm unable to enable RHEL 7 with Cloubbreak. I have already followed the above link earlier and tried below steps.

1. I created a Custom Image and it is ready in my AMI's.

2. I created the Image Catalog with custom setting for RHEL 7 Custom AMI and Cloudbreak is unable to recognize. (But custom Amazon Linux worked well with custom image catalog)

Can you help here?

Regards,

Ram

Super Collaborator

so you created your image catalog, that contained your RHEL7 image? And still the image is not recognized by Cloudbreak? Can you post your entry in the custom-image-catalog.json file? Perhaps you haven't configured your image with "images" : { "aws": { ... ? And as in the example for aws only amazonlinux is configured?

Expert Contributor

Also please add which CB version do you use

Contributor

Hey I was using CB 2.4.0 and found that I can upgrade to CB 2.7.1 which worked like a charm with Centos 7 and Thanks much @Harald Berghoff & @mmolnar.

Cheers,

Ram

Super Collaborator

Would be appreciated if you click on 'accept' for the answer. This will let all know the issue is resolved, and is rewarded by the platform.

New Contributor

I created a custom ami on AWS with RHEL7. 

registered the catalog in Cloudbreak.

when i try to launch cluster with the new registered image (i made ami public). The ami-id is not displayed. it prompts me with message 

 Image is required. The selected region is not supported by this image catalog