Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Hue Not working with hive on tez


Dear all 

I have installed CDP private cloud on single node, Also i added hive, hive-on-tez and Hue services but unfortunately Hue not working with hive database and hiveserver2 of hive-on-tez stopping frequently.

On hue UI this error is shown while choosing hive database

Could not connect to any of [('', 10000)] (code THRIFTTRANSPORT): TTransportException("Could not connect to any of [('', 10000)]",)


So what shall i do to work on hive using hue editor? 

thanks in advance 


Expert Contributor

Hi @dv_conan 


As you have mentioned that hiveserver2 of hive-on-tez is stopping frequently. This seems to be the cause of this error, as this message indicates that Hive Server is down or HUE Can't reach the server.


Please check Hive server logs to see why the hiveserver2 on hive-on-tez is failing frequently.



Hi @jAnshula 

Thanks for your reply,

I've already checked Hive server2 logs and this what i got in the screenshot below.

And i didn't find out what that error mean and how to solve it. am still cannot working with Hue  

Screenshot from 2021-08-25 16-43-30.png


Expert Contributor



It seems that Tez tar file is not uploaded to HDFS.

Can you try and manually upload the Tez tar file to HDFS manually


Go to CM  -> Tez  -> Actions  -> "Upload Tez tar file to HDFS.


Let us know if resolves your issue




I tried it but still not working and i have the same error !

Master Mentor

I think your issue should be resolved with this posting
Hive on tez issue
Please let me know if that resolves your problem or not 


I have seen that solution before, but it is also not working after i added this command to /etc/hive/conf/ 


and then restarted the service but hivserver2 still stopping frequently 


Could you please attach hive on Tez logs.


Please start Hive on Tez and wait till it crash completely and the provide the logs.


Please attach the logs from below location:

  a. /var/logs/hive

  b. /var/run/cloudera-scm-agent/process/<hove on tez>/logs


Please also try setting hive.server2.tez.initialize.default.sessions=false in CM  and check.

Community Manager

Hi @dv_conan Has any of the replies helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future.  If you are still experiencing the issue, can you provide the information that is requested?


Vidya Sargur,
Community Manager

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community: