Support Questions

Find answers, ask questions, and share your expertise

Hue Oozie: UnknownHostException error during submit workflow

Contributor

I have installed Hue 2.6 on my HDP 2.3.4 cluster and am trying to submit an Oozie workflow but am receiving the following error. I have tried troubleshooting based on the steps I found on the Apache wiki (link) without any success. I have included the logs but let me know if there is anything else I can provide that would be helpful.

4250-hue-oozie-error.jpg

hue-logs-146348982506.zip

1 ACCEPTED SOLUTION

Guru

In your configs for hue, I think you have 'namenode' as hdfs://irxvlndchad1.corp.irco.com.namenode.host:8020. Please change it right one. (hdfs://irxvlndchad1.corp.irco.com:8020)

View solution in original post

4 REPLIES 4

Guru

In your configs for hue, I think you have 'namenode' as hdfs://irxvlndchad1.corp.irco.com.namenode.host:8020. Please change it right one. (hdfs://irxvlndchad1.corp.irco.com:8020)

Contributor

@Ravi Mutyala You are right! Thanks for pointing that out. I fixed the configuration and was able to submit a job (the job I configured failed but that is another issue).

@Mark Thorson

Are you using Namenode HA? If Yes pls make sure you are pointing to right namenode.

For permanat resolution you can configure HUE httpfs to work HUE in HA cluster. Pls follow link below to configure HUE in HA cluster -

https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.3.0/bk_hadoop-ha/content/ha-nn-deploy-hue.html

Contributor

@Sagar Shimpi I am not using HA with this cluster (it is a small demo cluster) but I will take note of that for when we build future clusters. Thanks!