Support Questions
Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

Hue (Spark) Notebook with Kerberos Cloudera cluster

New Contributor
Hi there,
I am running Hue 3.11 (Cloudera 5.10) and trying to get Hue Notebook working with a Kerberised cluster. I got this working fine in Quickstart by installing Livy Server and adding the following in Hue Service Advanced Configuration Snippet (Safety Valve) for hue_safety_valve.ini:






# Configure Livy to start in local 'process' mode, or 'yarn' workers.
livy_server_session_kind = yarn

# Additional Settings for Livy server, Server url might be redundant
livy_server_session_timeout = 3600000

languages='[{"name": "Scala", "type": "scala"},{"name": "Python", "type": "python"},{"name": "Impala SQL", "type": "impala"},{"name": "Hive SQL", "type": "hive"},{"name": "Text", "type": "text"}]'

I installed Livy with the below environment variables set

export JAVA_HOME=/usr/java/jdk1.7.0_67-cloudera
export HUE_SECRET_KEY=cloudera
export HADOOP_CONF_DIR=/etc/hadoop/conf
export SPARK_HOME=/usr/lib/spark
This works ok for a cluster that does not have Kerberos enabled but I get errors when trying to do this same in a cluster that has Kerberos. I have tried various things based on a few spurious onine forums but cannot find any pointers online that seem to work, so I am wondering whether this is actually supported in Cloudera for Hue.
Is anyone able to help by letting me know exactly what I would need to change in Livy and in Hue (and anywhere else) to make Hue Notebook work when the Cloudera cluster has Kerberos enabled?

New Contributor

I have the same exact issue!. 

I created a keytab and kinited with the user running the livy server. I'm able to send http requests and run example jobs, like the PI approximation job.


I've also modified several hue.ini values via the safety valve, but nothing seems to work. I see regular notebooks that only displays HIVE, PIG, TEXT and MARKDOWN as languague options!.


What might be wrong??

New Contributor

Old post I know, but maybe someone will find this helpful.  I had this problem and solved it by adding the something like this to the Hue config:




The problem for me was the hostname defaulted to "localhost" which made hue use a silly kerberos principal.


This lets it all work but everyone runs as "livy"; when I enable impersonation everything breaks.... 😞