Support Questions
Find answers, ask questions, and share your expertise

I am getting error after upgrading Ambari from 2.4.3 to 2.5.1

Explorer

WARN [qtp-ambari-agent-4198] HeartBeatHandler:411 - Received registration request from host with non compatible agent version, hostname=xxx, agentVersion=2.4.3.0, serverVersion=2.5.1.0

1 ACCEPTED SOLUTION

Accepted Solutions

Re: I am getting error after upgrading Ambari from 2.4.3 to 2.5.1

@arjun more

You can try following on the xxx host,

On "xxx" host do the following,

# ambari-agent stop 
# yum remove ambari-agent -y 
# rm -rf /etc/ambari-agent/* 
# rm -rf /var/lib/ambari-agent/* 
# rm -f /usr/sbin/ambari-agent 
# rm -rf /usr/lib/python2.6/site-packages/ambari*
# rm -rf /usr/lib/python2.6/site-packages/resource_management
And now Install the ambari-agent,
# wget -nv http://public-repo-1.hortonworks.com/ambari/centos6/2.x/updates/2.5.1.0/ambari.repo -O /etc/yum.repos.d/ambari.repo
# yum install -y ambari-agent
# ambari-agent start 

This might solve's your problem.

View solution in original post

2 REPLIES 2

Re: I am getting error after upgrading Ambari from 2.4.3 to 2.5.1

@arjun more

You can try following on the xxx host,

On "xxx" host do the following,

# ambari-agent stop 
# yum remove ambari-agent -y 
# rm -rf /etc/ambari-agent/* 
# rm -rf /var/lib/ambari-agent/* 
# rm -f /usr/sbin/ambari-agent 
# rm -rf /usr/lib/python2.6/site-packages/ambari*
# rm -rf /usr/lib/python2.6/site-packages/resource_management
And now Install the ambari-agent,
# wget -nv http://public-repo-1.hortonworks.com/ambari/centos6/2.x/updates/2.5.1.0/ambari.repo -O /etc/yum.repos.d/ambari.repo
# yum install -y ambari-agent
# ambari-agent start 

This might solve's your problem.

View solution in original post

Re: I am getting error after upgrading Ambari from 2.4.3 to 2.5.1

Explorer

@nshelke,

Thanks for quick reply. I will try your suggestion.