Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

I have followed the Ambari ansible setup but the agents are not getting connected.

Highlighted

I have followed the Ambari ansible setup but the agents are not getting connected.

New Contributor

FAILED - RETRYING: Make sure all of the Ambari Agents have registered (1 retries left). failed: [master01] (item=slave02) => {"attempts": 10, "cache_control": "no-store", "changed": false, "connection": "close", "content_type": "text/plain;charset=utf-8", "date": "Mon, 05 Nov 2018 20:40:24 GMT", "expires": "Thu, 01 Jan 1970 00:00:00 GMT", "item": "slave02", "json": {"message": "The requested resource doesn't exist: Host not found, cluster=null, hostname=ip-xxxxxxxx.ec2.internal", "status": 404}, "msg": "HTTP Error 404: Not Found", "pragma": "no-cache", "redirected": false, "set_cookie": "AMBARISESSIONID=node0xxxxx.node0;Path=/;HttpOnly", "status": 404, "url": "http://ip-xxxx.ec2.internal:8080/api/v1/hosts/ip-xxxxx.ec2.internal", "user": "VALUE_SPECIFIED_IN_NO_LOG_PARAMETER", "x_content_type_options": "nosniff, nosniff", "x_frame_options": "DENY", "x_xss_protection": "1; mode=block"}

  • Checked IPtables
  • Checked ports
  • Checked sshless setup
2 REPLIES 2

Re: I have followed the Ambari ansible setup but the agents are not getting connected.

Super Mentor

@Raja Tejas

Can you please share the complete Ambari Server log along with the Ambari Agent log. Better try restarting agent once again and then share the fresh logs.

"/var/log/ambari-server/ambari-server.log"

"/var/log/ambari-agent/ambari-agent.log"

Also please make sure that the FQDN of all your hosts including ambari server and agent hosts are set correctly so that the following command returns the desired name.

# hostname -f

# cat /etc/hosts

.

Re: I have followed the Ambari ansible setup but the agents are not getting connected.

New Contributor

/etc/hosts are configured by ansible setup. I refered to this https://github.com/hortonworks/ansible-hortonworks

  • Default setup does not turn off the firewalls in amazon distro by default. Hence stopping the firewalld worked.
  • Furthermore turning off the selinux on amazon-redhat is failing the cluster creation.

Now, All the configured services have connection issues even after configuring security groups to allow All ICMP and TCP traffic to itself to install a basic HDF 3.2 cluster. ERROR Logs: server-log.txt . agent-logs.txt