Support Questions

Find answers, ask questions, and share your expertise

I tried to run a sqoop job to import table from mysql via ozzie but I am getting an error : it seems that you have launched a sqoop metastore job via oozie with sqoop.metastore.client.record.password disabled.

I have set sqoop.metastore.client.record.password true in sqoop-site.xml.
Also shows that java.sql.SQLException: Access denied for user 'root'@'slnxhadoopUrl' (using password: NO)
java.sql.SQLException: Access denied for user 'root'@'slnxhadoopUrl' (using password: NO

access is given to the root user in MYSQL.


@Shobhna Dhami

This is a permission issue for the user root,can you run the below as root while logged on mysql

mysql> grant all privileges on *.* to 'root'@'' identified by 'root_password';

Please revert


Hi Thanks @ Geoffrey Shelton Okot

I have given all privileges to root user but still I am getting same error.

I have 4 nodes in cluster and each of them have all privileges in MYSQL.

My oozie workfile document :

<workflow-app xmlns = "uri:oozie:workflow:0.4" name = "simple-Workflow">

<start to = "run_sqoop_job" /> <!-- step 1 -->

<action name = "run_sqoop_job">

<sqoop xmlns="uri:oozie:sqoop-action:0.2">


<name-node>${nameNode}</name-node><command>job --meta-connect "jdbc:hsqldb:hsql://ooozie MetastoreUrl:16001/sqoop" --exec samplejob</command> </sqoop> <ok to = "end"/>

<error to = "fail"/>


<kill name = "fail">

<message>workflow fail</message>


<end name = "end"/>



property file:

resourceManager = resource manager url:port

nameNode = hdfs:// hdfs://hdfs url:port/shared/emproot/workflow/sqoop_job_run.xml oozie.use.system.libpath = true