Support Questions
Find answers, ask questions, and share your expertise

If running a Mahout DistributedLanczosSolver Job an IncompatibleClassChangeError occurs!

Contributor

Hello Colleagues,

 

if i run a  Mahout DistributedLanczosSolver Job the following error were thrown from the LanczosSolver :

 

Exception in thread "main" java.lang.IncompatibleClassChangeError: class org.apache.mahout.math.decomposer.lanczos.LanczosSolver$Scale has interface org.apache.mahout.math.function.DoubleFunction as super class

I'm using CDH 5.3.2 and the mahout 0.9 packages for CDH 5.3.2.

 

If i started the job a map reduce job is was finished and the following log message were shown:

INFO lanczos.LanczosSolver: 1 passes through the corpus so far...

After this, the error message above occurs.

 

Do you have any ideas or a soloution regarding this issue?

 

Thanks and regards,

 butkiz

 

 

1 ACCEPTED SOLUTION

Master Collaborator

This kind of thing means you've got a mismatch somewhere between library versions. Are you packaging a different version of Mahout with your app? do you have old copies of the library somewhere on a classpath?

View solution in original post

2 REPLIES 2

Master Collaborator

This kind of thing means you've got a mismatch somewhere between library versions. Are you packaging a different version of Mahout with your app? do you have old copies of the library somewhere on a classpath?

Contributor
Thanks a lot! The jar "mahout-1.0-collections.jar" was present in the class path. I've removed this jar and the job works without an error message. Best regards, butkiz!
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.