Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Impala 32Bit vs 64bit ODBC

Solved Go to solution

Impala 32Bit vs 64bit ODBC

Rising Star

Hi,

I've got a user who's 32bit ODBC impala connection is fine, but the 64bit gives the the "unspeficied GSS error"

There is no difference between the two connections and no one else is epereincing this problem.

Any ideas?!?!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Impala 32Bit vs 64bit ODBC

Rising Star

Just incase anyone has this problem in the future, the issue was reolved by enabling "Enable for this DSN" option under use only SSPI inside the advanced options.

I'm not sure why this user needed to do that and no other use has, but seems to have worked.

3 REPLIES 3

Re: Impala 32Bit vs 64bit ODBC

Cloudera Employee

Its difficult to say what might be going on without more information, but a few pieces of info  that may be helpful to you:
- "Unspecified GSS error" generally indicates an issue with Kerberos authentication.

- The bitness of the ODBC driver must match the bitness of the client application in order for everything to work correctly.

 

From your description, it may be that the user is using a 32bit Kerberos client, in which case it is expected that the 64bit ODBC driver would not work with it.

 

Given that the 32bit connection is fine, what's the motivation for trying to get the 64 bit driver to work?

Re: Impala 32Bit vs 64bit ODBC

Rising Star

Hi,

It was when acctually setting up the ODBC within windows.

Create ODBC within windows DSN 32 bit works ok.  It's the creating an ODBC within 64bit that doesnt.

There is no client applicaiton even involved at this point yet.

On my machine both 32/64bit can be created, so there must be something different on this users windows machine, i'm stumped!

Re: Impala 32Bit vs 64bit ODBC

Rising Star

Just incase anyone has this problem in the future, the issue was reolved by enabling "Enable for this DSN" option under use only SSPI inside the advanced options.

I'm not sure why this user needed to do that and no other use has, but seems to have worked.