Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-10-2022 11:55 PM
Hello,
we have Impala issue last days with regularly Impala Catalog Server restart.
Access data via Impala works, but Cloudera Manager sent alerts every 5 minutes with
IllegalStateException: Table.toThrift() called without holding the table lock: table_name
We tried to invalidate metadata on table and compute stats, but no success.
It works normally before and there were no changes on cluster.
Have you any idea what is the problem?
Regards
Kamil
Created 01-13-2022 02:08 AM
@Kamil_Valko, Has the reply helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future.
Regards,
Vidya Sargur,Created 01-11-2022 01:21 AM
Hi @Kamil_Valko ,
The error message suggests that you are hitting IMPALA-9136 which is fixed in CDH 6.3.4 and in CDP 7.1.0 and newer.
The regular Catalogd restart is likely due to some other problems, please file a support case to be able to review it in more detail.
You can also review the role or the stdout/stderr logs of the Catalog daemon, maybe it shows an OutOfMemoryError - which can be common if the HMS / catalog metadata has increased recently - and the catalog heap is not adjusted.
Best regards
Miklos
Created 01-13-2022 02:08 AM
@Kamil_Valko, Has the reply helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future.
Regards,
Vidya Sargur,Created 01-16-2022 11:42 PM
Hello,
problem was with OOO memory, after add some, it looks ok.
Thank for advice.
Best regards
Kamil