Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Impala Catalogd and statestore connection issues

avatar
Contributor

We faced an issue in our Impala environment:

Refresh to any of the impala tables were getting failed while when we query any tables like select count * , it was working.

We found that the catalogd lost its connection to statestored. The catalog logs show:

Connection with statestore lost, entering recovery mode.

Trying to re-register with statestore, attempt: 1

TSocket::write_partial() send() <Host: ipaddress Port: 53164>Broken pipe

 

While the statestored logs shows:

Missed subscriber (catalog-server@servername:26000) heartbeat deadline by 8971ms, consider increasing --statestore_heartbeat_frequency_ms (currently 1000)

 

Can someone advise what could be the issue.

Both Statstore and catalog daemons are on the same node.

1 REPLY 1

avatar
Master Collaborator

Hi @swapko ,

 

> Please provide the error stacktrace that you are seeing when you refresh the impala tables.

> was it working earlier?

 

Regards,

Chethan YM